aboutsummaryrefslogtreecommitdiffstats
path: root/testing/syndication
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-28 22:30:01 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-29 19:16:52 +0000
commit8bd42972c0f623e1c7debdbd6a53a4138c3ed95e (patch)
tree6ab81c1b7d08c1c1cb3ea294a519cf148351cae3 /testing/syndication
parent80476f35c5ab45ce47a5bd8234bd8ba7273ad322 (diff)
downloadaports-8bd42972c0f623e1c7debdbd6a53a4138c3ed95e.tar.bz2
aports-8bd42972c0f623e1c7debdbd6a53a4138c3ed95e.tar.xz
testing/syndication: new aport
Closes GH-8204
Diffstat (limited to 'testing/syndication')
-rw-r--r--testing/syndication/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/syndication/APKBUILD b/testing/syndication/APKBUILD
new file mode 100644
index 0000000000..25d77b316e
--- /dev/null
+++ b/testing/syndication/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=syndication
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="An RSS/Atom parser library"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.0-or-later AND BSD-Clause-3"
+depends_dev="qt5-qtbase-dev kcodecs-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="fbd3283e37f906b7bde76332721004ad679e99b4d8b3700ee0e98986f14a45dfd32048673d4e5270c351868c6e0f212b17bc4e4bc47f003cee4eb4dd16f9abd6 syndication-5.58.0.tar.xz"