aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tarantool
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-20 18:36:56 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-21 18:12:22 +0100
commit539c11eaf78c3222296d07f8ef36572563ffd918 (patch)
tree816d69eeeb73df651583816e5ea03f2477020d4b /testing/tarantool
parentc7a1f20490e2882233bfdfa682040d3cb0ffd967 (diff)
downloadaports-539c11eaf78c3222296d07f8ef36572563ffd918.tar.bz2
aports-539c11eaf78c3222296d07f8ef36572563ffd918.tar.xz
testing/*: make CMake and meson respect our C{,PP,XX}FLAGS
See: https://lists.alpinelinux.org/~alpine/devel/%3C2896c13070c508a49cbaa72c8fb7f34ea947358b.camel%40cogitri.dev%3E
Diffstat (limited to 'testing/tarantool')
-rw-r--r--testing/tarantool/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/tarantool/APKBUILD b/testing/tarantool/APKBUILD
index 2e9d25f5b4..dc90f660d2 100644
--- a/testing/tarantool/APKBUILD
+++ b/testing/tarantool/APKBUILD
@@ -4,7 +4,7 @@
pkgname=tarantool
pkgver=1.7.4.335
_series=${pkgver%.*}; _series=${_series%.*} # x.y
-pkgrel=7
+pkgrel=8
pkgdesc="Lua application server integrated with a database management system"
url="https://tarantool.org"
# x86, aarch64: fails to build
@@ -55,7 +55,7 @@ build() {
# - luajit (MIT): tarantool requires non-exported symbols, so cannot link
# dynamically; linking with system static libluajit doesn't work too
cmake \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \