aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tcpreplay
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-04-08 20:36:21 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:46:34 +0000
commite458e286b9028cbc1d13f98fa56987a9ef640001 (patch)
tree6b0321e21793f615814f51e3040df5731049a42e /testing/tcpreplay
parent16c1df671390e20df9c8b0ac89fa1aafb8484bf5 (diff)
downloadaports-e458e286b9028cbc1d13f98fa56987a9ef640001.tar.bz2
aports-e458e286b9028cbc1d13f98fa56987a9ef640001.tar.xz
testing/tcpreplay: new aport
Tcpreplay is a suite of tools for UNIX operating systems which gives you the ability to use previously captured traffic in libpcap format to test a variety of network devices. It allows you to classify traffic as client or server, rewrite Layer 2, 3 and 4 headers and finally replay the traffic back onto the network and through other devices such as switches, routers, firewalls, NIDS and IPS's. Tcpreplay supports both single and dual NIC modes for testing both sniffing and inline devices. http://tcpreplay.synfin.net/
Diffstat (limited to 'testing/tcpreplay')
-rw-r--r--testing/tcpreplay/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/tcpreplay/APKBUILD b/testing/tcpreplay/APKBUILD
new file mode 100644
index 0000000000..6d56148e21
--- /dev/null
+++ b/testing/tcpreplay/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=tcpreplay
+pkgver=3.4.4
+pkgrel=0
+pkgdesc="Replay captured network traffic"
+url="http://tcpreplay.synfin.net/trac/"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="libdnet-dev libpcap-dev tcpdump"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-dynamic-link \
+ --enable-tcpreplay-edit \
+ --enable-local-libopts \
+ --disable-libopts-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="22725feb9b2590809f9350308ec65180 tcpreplay-3.4.4.tar.gz"