aboutsummaryrefslogtreecommitdiffstats
path: root/testing/udftools
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-26 22:51:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-26 22:29:59 -0300
commitdb29a597b9420ad31b613dd8cae5d3405ab41ca9 (patch)
treed8ff345d08f5f1a647effc66fc88dffc49646ee2 /testing/udftools
parent40bea718401af7d8155dceec058a8a1d68019ff1 (diff)
downloadaports-db29a597b9420ad31b613dd8cae5d3405ab41ca9.tar.bz2
aports-db29a597b9420ad31b613dd8cae5d3405ab41ca9.tar.xz
testing/udftools: new aport
Diffstat (limited to 'testing/udftools')
-rw-r--r--testing/udftools/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/udftools/APKBUILD b/testing/udftools/APKBUILD
new file mode 100644
index 0000000000..0d77cc7d08
--- /dev/null
+++ b/testing/udftools/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=udftools
+pkgver=2.1
+pkgrel=0
+arch="all"
+url="https://github.com/pali/udftools/"
+pkgdesc="Tools for UDF filesystems and DVD/CD-R(W) drives"
+license="GPL-2.0-or-later"
+makedepends="automake autoconf libtool eudev-dev linux-headers"
+source="https://github.com/pali/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="0bdb3f2e0595200dadb771af4f31ba513d0bf6a0fbd30bc3a1f8aba4ab5f487f61635e65dc155926d2f566cb6e2b2f3a57938071616058cf703692d529971a64 udftools-2.1.tar.gz"