aboutsummaryrefslogtreecommitdiffstats
path: root/testing/virt-what
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-09-08 20:04:09 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 14:45:04 +0000
commitbe518492044d40633d47c883b6e788d1ddcbc7ba (patch)
tree11a608511ea4f4cab406d55048f2baf828ea0846 /testing/virt-what
parent041e0f9c4faff947c22398af85ec534b4c4369e8 (diff)
downloadaports-be518492044d40633d47c883b6e788d1ddcbc7ba.tar.bz2
aports-be518492044d40633d47c883b6e788d1ddcbc7ba.tar.xz
testing/virt-what: add checkbashisms to check()
Diffstat (limited to 'testing/virt-what')
-rw-r--r--testing/virt-what/APKBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/testing/virt-what/APKBUILD b/testing/virt-what/APKBUILD
index 400a90b595..906192e972 100644
--- a/testing/virt-what/APKBUILD
+++ b/testing/virt-what/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Detect if we are running in a virtual machine"
url="https://people.redhat.com/~rjones/virt-what/"
arch="x86 x86_64 ppc64le"
license="GPL2+"
+checkdepends="checkbashisms"
makedepends="automake autoconf perl-dev"
subpackages="$pkgname-doc"
source="http://people.redhat.com/~rjones/$pkgname/files/$pkgname-$pkgver.tar.gz
@@ -33,6 +34,8 @@ build() {
check() {
cd "$builddir"
make check
+
+ checkbashisms ./virt-what
}
package() {