aboutsummaryrefslogtreecommitdiffstats
path: root/testing/virtualbox-guest-modules
diff options
context:
space:
mode:
authorBen Allen <bensallen@me.com>2016-01-22 04:40:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-09 17:25:30 +0000
commitb43b8fae5e6c22aaf5e76899948942a50a6a0b6b (patch)
treebcd4cf61ad40d3a16f9e056027c2bc2889c0ace5 /testing/virtualbox-guest-modules
parent0eefec77f9a34bc43d9bd32d43d42ba746bc2af1 (diff)
downloadaports-b43b8fae5e6c22aaf5e76899948942a50a6a0b6b.tar.bz2
aports-b43b8fae5e6c22aaf5e76899948942a50a6a0b6b.tar.xz
testing/virtualbox-guest-modules: new aport
- Virtualbox Guest Additions kernel modules: vboxguest and vboxsf.
Diffstat (limited to 'testing/virtualbox-guest-modules')
-rw-r--r--testing/virtualbox-guest-modules/10-vboxguest-Makefile.patch11
-rw-r--r--testing/virtualbox-guest-modules/APKBUILD71
2 files changed, 82 insertions, 0 deletions
diff --git a/testing/virtualbox-guest-modules/10-vboxguest-Makefile.patch b/testing/virtualbox-guest-modules/10-vboxguest-Makefile.patch
new file mode 100644
index 0000000000..2e1b591175
--- /dev/null
+++ b/testing/virtualbox-guest-modules/10-vboxguest-Makefile.patch
@@ -0,0 +1,11 @@
+--- VirtualBox-5.0.12/vboxguest/Makefile.orig
++++ VirtualBox-5.0.12/vboxguest/Makefile
+@@ -108,7 +108,7 @@
+
+ MOD_DEFS = -DVBOX -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_GUEST \
+ -DIN_GUEST_R0 -DIN_MODULE -DRT_WITH_VBOX -DVBGL_VBOXGUEST \
+- -DVBOX_WITH_HGCM
++ -DVBOX_WITH_HGCM -DLOG_USE_C99
+ ifeq ($(BUILD_TARGET_ARCH),amd64)
+ MOD_DEFS += -DRT_ARCH_AMD64
+ else
diff --git a/testing/virtualbox-guest-modules/APKBUILD b/testing/virtualbox-guest-modules/APKBUILD
new file mode 100644
index 0000000000..1e3ff105f4
--- /dev/null
+++ b/testing/virtualbox-guest-modules/APKBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Ben Allen <bensallen@me.com>
+# Contributor: Ben Allen <bensallen@me.com>
+
+_flavor=${FLAVOR:-grsec}
+_kpkg=linux-$_flavor
+_kver=4.1.15
+_kpkgrel=5
+
+# when chaning _ver we *must* bump _mypkgrel
+_ver=5.0.14
+_mypkgrel=0
+_name=virtualbox-guest-modules
+
+# verify the kernel version before entering chroot
+_kapkbuild=../../linux-${_flavor}/APKBUILD
+if [ -f $_kapkbuild ]; then
+ . $_kapkbuild
+ pkgname=$_name-$_flavor
+ [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
+ [ "$_kpkgrel" != "$pkgrel" ] && die "please update _kpkgrel to $pkgrel"
+fi
+
+_kpkgver="$_kver-r$_kpkgrel"
+_abi_release=${_kver}-${_kpkgrel}-${_flavor}
+
+pkgname=${_name}-${_flavor}
+pkgver=$_kver
+pkgrel=$(($_kpkgrel + $_mypkgrel))
+pkgdesc="VirtualBox Additions kernel modules for $_flavor "
+arch='x86_64'
+url='http://virtualbox.org'
+license="GPL custom"
+makedepends="linux-grsec-dev sed"
+source="http://download.virtualbox.org/virtualbox/$_ver/VirtualBox-$_ver.tar.bz2
+ 10-vboxguest-Makefile.patch"
+
+_builddir="$srcdir"/VirtualBox-$_ver
+
+prepare() {
+ cd "$_builddir"
+ $_builddir/src/VBox/Additions/linux/export_modules "$_builddir/vbox-kmod.tar.gz"
+ tar -xf "$_builddir/vbox-kmod.tar.gz"
+ local i
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # Build Kernel Modules
+ make KERN_DIR=/lib/modules/${_abi_release}/build
+}
+
+package() {
+ cd "$_builddir"
+ local module=
+ for module in vboxsf vboxguest; do
+ install -v -D -m644 ${module}.ko \
+ "$pkgdir/lib/modules/${_abi_release}/misc/${module}.ko"
+ done
+}
+
+md5sums="e0a02426ad09b475e630881efe911423 VirtualBox-5.0.14.tar.bz2
+34c8e3cb497d86be4281dcd62b3b3b4f 10-vboxguest-Makefile.patch"
+sha256sums="69abac7255b2251a18fd73c0b7c200d5f8ce72a59fa019b53a5cdbf7f2843002 VirtualBox-5.0.14.tar.bz2
+440a4c15e7de4ad9087fedc64c045c6a28f31c59c787ad7a8a34ea65b72f8499 10-vboxguest-Makefile.patch"
+sha512sums="5547da58b50c9cf5d096f81c005134e1f56c4fb55d4d40a6fbd1efe1fe1fbeebc0747f0903933da9238a24c63eeed2c6c15bfc5cae5ce6e3e2eb4a18511d6258 VirtualBox-5.0.14.tar.bz2
+38f774b8b2242687dc6327bd4c2fc6951207758fb2e25dd46550861c09a3f2b8efad1a8414529146fbbb8a89cf2eb3ad44b00fbdbbeafd3f8c69ba4cb91decf0 10-vboxguest-Makefile.patch"