aboutsummaryrefslogtreecommitdiffstats
path: root/testing/waybar
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 15:34:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 15:34:52 -0300
commitc5d6fa69a7e34573ae5e8edf81733f3f6fb56d43 (patch)
treeb747a8270bc9f713d17b402985c967f92a870355 /testing/waybar
parent15b008686124ed5ff46c4b035a1cc321be8a72a2 (diff)
downloadaports-c5d6fa69a7e34573ae5e8edf81733f3f6fb56d43.tar.bz2
aports-c5d6fa69a7e34573ae5e8edf81733f3f6fb56d43.tar.xz
testing/waybar: rebuild against libfmt.so.6
Diffstat (limited to 'testing/waybar')
-rw-r--r--testing/waybar/APKBUILD9
-rw-r--r--testing/waybar/fix-build.patch40
2 files changed, 46 insertions, 3 deletions
diff --git a/testing/waybar/APKBUILD b/testing/waybar/APKBUILD
index 6fc2f2f416..9a94f7b127 100644
--- a/testing/waybar/APKBUILD
+++ b/testing/waybar/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname="waybar"
pkgver="0.7.2"
-pkgrel=0
+pkgrel=1
pkgdesc="Highly customizable Wayland bar for Sway and Wlroots based compositors"
url="https://github.com/Alexays/Waybar/"
arch="all"
@@ -10,7 +10,9 @@ license="MIT"
depends="ttf-font-awesome"
makedepends="meson gtkmm3-dev jsoncpp-dev spdlog-dev fmt-dev libinput-dev
libnl3-dev pulseaudio-dev libmpdclient-dev eudev-dev"
-source="Waybar-$pkgver.tar.gz::https://github.com/Alexays/Waybar/archive/$pkgver.tar.gz"
+source="Waybar-$pkgver.tar.gz::https://github.com/Alexays/Waybar/archive/$pkgver.tar.gz
+ fix-build.patch
+ "
options="!check" # No test suite
builddir="$srcdir/Waybar-$pkgver"
@@ -29,4 +31,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="d83f92d0111cdd01b276907fad18344dbf35be1e0bbbce2208f928e0d5e0fcccfa65ff2279de5a7e4dad5f04a6c99521670d75d65e32a0382bec2bf32eea00e2 Waybar-0.7.2.tar.gz"
+sha512sums="d83f92d0111cdd01b276907fad18344dbf35be1e0bbbce2208f928e0d5e0fcccfa65ff2279de5a7e4dad5f04a6c99521670d75d65e32a0382bec2bf32eea00e2 Waybar-0.7.2.tar.gz
+255db16accb05d07417f3b05b3096385529f78371191f4fb941412b732a6b2a7e81ce9d5ffb04117a6cc83bc82d6f0f4dbffe9b7c8a350d7c5ce7eb2a75c3f55 fix-build.patch"
diff --git a/testing/waybar/fix-build.patch b/testing/waybar/fix-build.patch
new file mode 100644
index 0000000000..32da7a98c1
--- /dev/null
+++ b/testing/waybar/fix-build.patch
@@ -0,0 +1,40 @@
+diff --git a/include/modules/clock.hpp b/include/modules/clock.hpp
+index b812b70..4a0c1e5 100644
+--- a/include/modules/clock.hpp
++++ b/include/modules/clock.hpp
+@@ -1,8 +1,8 @@
+ #pragma once
+
++#include <fmt/chrono.h>
+ #include <fmt/format.h>
+ #include "ALabel.hpp"
+-#include "fmt/time.h"
+ #include "util/sleeper_thread.hpp"
+
+ namespace waybar::modules {
+diff --git a/src/bar.cpp b/src/bar.cpp
+index 8a45869..8e64349 100644
+--- a/src/bar.cpp
++++ b/src/bar.cpp
+@@ -1,7 +1,7 @@
+ #include "bar.hpp"
+-#include <spdlog/spdlog.h>
+ #include "client.hpp"
+ #include "factory.hpp"
++#include <spdlog/spdlog.h>
+
+ waybar::Bar::Bar(struct waybar_output* w_output, const Json::Value& w_config)
+ : output(w_output),
+diff --git a/src/modules/sni/host.cpp b/src/modules/sni/host.cpp
+index 015f756..c815c65 100644
+--- a/src/modules/sni/host.cpp
++++ b/src/modules/sni/host.cpp
+@@ -1,6 +1,6 @@
+ #include "modules/sni/host.hpp"
+-#include <spdlog/spdlog.h>
+ #include <fmt/ostream.h>
++#include <spdlog/spdlog.h>
+
+ namespace waybar::modules::SNI {
+
+