aboutsummaryrefslogtreecommitdiffstats
path: root/testing/waypipe
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-21 01:30:34 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-21 06:54:18 +0000
commitda63fe9821942bdb0861ab2207f3f28a9d58e76a (patch)
tree926fab8dfd28d8cf967ce44c88162ed60b479fb7 /testing/waypipe
parent879e9251bb2f6447dec57a328381b38e75e53ef2 (diff)
downloadaports-da63fe9821942bdb0861ab2207f3f28a9d58e76a.tar.bz2
aports-da63fe9821942bdb0861ab2207f3f28a9d58e76a.tar.xz
testing/waypipe: remove prepare function
- update package description - add check function (but still disabled for now)
Diffstat (limited to 'testing/waypipe')
-rw-r--r--testing/waypipe/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/testing/waypipe/APKBUILD b/testing/waypipe/APKBUILD
index b3acd938f9..c91309e4f7 100644
--- a/testing/waypipe/APKBUILD
+++ b/testing/waypipe/APKBUILD
@@ -1,29 +1,31 @@
# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
-pkgname="waypipe"
-pkgver="0.6.1"
-pkgrel=1
-pkgdesc="A proxy for Wayland protocol applications."
+pkgname=waypipe
+pkgver=0.6.1
+pkgrel=2
+pkgdesc="A proxy for Wayland clients"
url="https://gitlab.freedesktop.org/mstoeckl/waypipe"
arch="all"
license="MIT"
-makedepends="meson wayland-protocols wayland-dev scdoc cmake lz4-dev mesa-gbm libdrm-dev libva-dev"
+makedepends="meson wayland-protocols wayland-dev scdoc lz4-dev mesa-gbm libdrm-dev libva-dev"
source="https://gitlab.freedesktop.org/mstoeckl/waypipe/-/archive/v$pkgver/waypipe-v$pkgver.tar.gz"
-options="!check"
-builddir="$srcdir/$pkgname-v$pkgver"
+options="!check" # not all tests pass
subpackages="$pkgname-doc"
+builddir="$srcdir/$pkgname-v$pkgver"
-prepare() {
- meson build \
+build() {
+ meson \
+ --buildtype=plain \
--prefix=/usr \
--mandir=/usr/share/man \
- --buildtype=plain \
-Dwerror=false \
- -Db_ndebug=true
+ -Db_ndebug=true \
+ build
+ ninja -C build
}
-build() {
- ninja -C build
+check() {
+ ninja -C build test
}
package() {