aboutsummaryrefslogtreecommitdiffstats
path: root/testing/weston
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-25 14:24:16 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 08:13:01 -0300
commitbb0921051311fb3090671abeac99983ef37a2f33 (patch)
tree5005d99342f978ed7290ce44396b17bd6f3e6a3b /testing/weston
parent31a7736df5e90c04eabd6df2ee3ae348919ffbf1 (diff)
downloadaports-bb0921051311fb3090671abeac99983ef37a2f33.tar.bz2
aports-bb0921051311fb3090671abeac99983ef37a2f33.tar.xz
testing/weston: enable logind support via elogind
Diffstat (limited to 'testing/weston')
-rw-r--r--testing/weston/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/testing/weston/APKBUILD b/testing/weston/APKBUILD
index bbe3dece46..f8cbf3a753 100644
--- a/testing/weston/APKBUILD
+++ b/testing/weston/APKBUILD
@@ -2,19 +2,19 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=weston
pkgver=6.0.0
-pkgrel=0
+pkgrel=1
_libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
pkgdesc="The reference Wayland server"
url="https://wayland.freedesktop.org/"
arch="all !s390x !ppc64le"
license="MIT"
-depends=""
makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
libinput-dev libunwind-dev mtdev-dev libxcursor-dev glu-dev
pango-dev colord-dev libwebp-dev libva-dev dbus-dev
linux-pam-dev wayland-dev libevdev-dev libjpeg-turbo-dev
freerdp-dev lcms2-dev gstreamer-dev gst-plugins-base-dev meson
+ elogind-dev
"
_cms="cms-colord cms-static"
_shell="shell-desktop shell-fullscreen shell-ivi"
@@ -33,16 +33,14 @@ source="https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
timespec.patch
weston-launch-custom-error-function.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
# weston-launch requires suid
options="!check suid"
install="$pkgname.pre-install"
build() {
- cd "$builddir"
meson \
-Dprefix=/usr \
- -Dlauncher-logind=false \
+ -Dlauncher-logind=true \
-Dsystemd=false \
-Dsimple-dmabuf-drm=auto \
build