aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wmi-client
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-12-12 20:19:49 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-13 18:26:18 +0000
commit4f6881473b58fac44a53d34989157bd650bec56f (patch)
tree3d8b42235ad60499220a950471f1d1ac9e4d0481 /testing/wmi-client
parentcfd2de0d16a582c5b430250d91e0b16fc020e995 (diff)
downloadaports-4f6881473b58fac44a53d34989157bd650bec56f.tar.bz2
aports-4f6881473b58fac44a53d34989157bd650bec56f.tar.xz
testing/wmi-client: update patch for new wmi version
Diffstat (limited to 'testing/wmi-client')
-rw-r--r--testing/wmi-client/APKBUILD6
-rw-r--r--testing/wmi-client/openvas-wmi-1.3.16.patch (renamed from testing/wmi-client/openvas-wmi-1.3.14.patch)12
2 files changed, 9 insertions, 9 deletions
diff --git a/testing/wmi-client/APKBUILD b/testing/wmi-client/APKBUILD
index 3139bb1bb4..2212e6913b 100644
--- a/testing/wmi-client/APKBUILD
+++ b/testing/wmi-client/APKBUILD
@@ -3,7 +3,7 @@
pkgname=wmi-client
_pkgname="${pkgname/-*/}"
pkgver=1.3.16
-pkgrel=1
+pkgrel=2
pkgdesc="DCOM/WMI client implementation"
url="https://www.orvant.com/packages"
arch="all !aarch64"
@@ -11,7 +11,7 @@ license="GPL3"
subpackages="libwmiclient-dev:libdev libwmiclient:lib"
makedepends="autoconf python-dev perl-datetime"
source="https://launchpad.net/~cybersec/+archive/ubuntu/chaos-ppa-v2/+files/${_pkgname}_${pkgver}.orig.tar.bz2
- openvas-wmi-1.3.14.patch
+ openvas-wmi-1.3.16.patch
samba-pidl.patch
pyinclude.patch
perl-support.patch
@@ -53,7 +53,7 @@ lib() {
}
sha512sums="cd5ccf23dff59dd599ae23b4cd8d0d68f42775b2afad8e05add04d0d4054cbb8e33655323b1d87795f23a71b6c0c0e260e38f53349c77618d2421862d172a508 wmi_1.3.16.orig.tar.bz2
-af97edd7d37864cddcd02c9f66beb940058138964113f2687dc5a3d62a0b0b60524a9ba7f5ecdc8b1d4f99b2fd2805086d9953556b77e8b78891e74694735293 openvas-wmi-1.3.14.patch
+be7ac5248336e5f308c23a4df7d41f061de6397855b376070f8d2c987187fe9e5bdfe5d61f9e21cf8480774c66be2581c8752627d7cbf5588be2223a91239d90 openvas-wmi-1.3.16.patch
cc0bbeb6805bb38898ced7956ed313c6cf67c11316eb2906a353fc227d1dc538fc8ce689035fee865f42e7bd13d4f74b5f12b925399f64cb22ea110da4ae9f9a samba-pidl.patch
5d2073fe0313e92c10fdaee7fd65d2d26e1a2ac1ec70955b2009c8aaad33a4944a2a8f354d416ac346cc0c43b04b1ffe95ee012cd77ddb74a7459d67f44aec4b pyinclude.patch
74f1172cf3d5297ea9be473acf0fcdaeb3e199b9922054eea427999ab571400c1817f3734a385d9c85f4dfad3a85e57ff1970df2c023e972fb6985dec8a9dbae perl-support.patch
diff --git a/testing/wmi-client/openvas-wmi-1.3.14.patch b/testing/wmi-client/openvas-wmi-1.3.16.patch
index 5f888805a9..13d5a27c87 100644
--- a/testing/wmi-client/openvas-wmi-1.3.14.patch
+++ b/testing/wmi-client/openvas-wmi-1.3.16.patch
@@ -74,7 +74,7 @@ diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch'
--- wmi-1.3.14~/Samba/source/install-libwmiclient.sh 1969-12-31 17:00:00.000000000 -0700
+++ wmi-1.3.14/Samba/source/install-libwmiclient.sh 2011-02-26 11:32:55.000000000 -0700
@@ -0,0 +1,40 @@
-+#!/bin/bash
++#!/bin/sh
+
+if [ -z $1 ] ; then
+ PREFIX="/usr"
@@ -102,14 +102,14 @@ diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch'
+
+PCFILE="$LIBDIR/pkgconfig/wmiclient.pc"
+
-+echo "prefix=$PREFIX" > $PCFILE
-+echo "exec_prefix=$PREFIX" >> $PCFILE
-+echo "libdir=$LIBDIR" >> $PCFILE
-+echo "includedir=$PREFIX/include" >> $PCFILE
++echo "prefix=/usr" > $PCFILE
++echo "exec_prefix=/usr" >> $PCFILE
++echo "libdir=/usr/lib" >> $PCFILE
++echo "includedir=/usr/include" >> $PCFILE
+echo "" >> $PCFILE
+echo "Name: wmiclient" >> $PCFILE
+echo "Description: wmiclient library for OpenVAS" >> $PCFILE
-+echo "Version: 1.3.14" >> $PCFILE
++echo "Version: 1.3.16" >> $PCFILE
+echo "Requires:" >> $PCFILE
+echo "Cflags: -I\${includedir} -I\${includedir}/openvas" >> $PCFILE
+echo "Libs: -L\${libdir}" >> $PCFILE