aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xdg-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-25 20:11:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-25 20:11:26 +0000
commite18a27badf95d1329ab44c8fd52360004c012728 (patch)
tree22b7db8ad31ad943bbd18f8070ed105c43fbce9a /testing/xdg-utils
parent8fb755341f7badfade3de5d5dff1d81df6ab244f (diff)
downloadaports-e18a27badf95d1329ab44c8fd52360004c012728.tar.bz2
aports-e18a27badf95d1329ab44c8fd52360004c012728.tar.xz
testing/xdg-utils: new aport
Basic desktop integration functions http://portland.freedesktop.org/wiki/
Diffstat (limited to 'testing/xdg-utils')
-rw-r--r--testing/xdg-utils/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/xdg-utils/APKBUILD b/testing/xdg-utils/APKBUILD
new file mode 100644
index 0000000000..70b268c23e
--- /dev/null
+++ b/testing/xdg-utils/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xdg-utils
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Basic desktop integration functions"
+url="http://portland.freedesktop.org/wiki/"
+arch="all"
+license="MIT"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-doc"
+source="http://portland.freedesktop.org/download/xdg-utils-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="348a5b91dc66426505022c74a64b2940 xdg-utils-1.0.2.tgz"