aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xen
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-13 13:42:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-13 13:42:26 +0000
commitaaf7501518d7db71e8bdb626dfba002306cea940 (patch)
tree5942c969d154ab67266cedb107110814686c2f96 /testing/xen
parent67a31c02220ce28b7b87464e3a687f2effdcc083 (diff)
downloadaports-aaf7501518d7db71e8bdb626dfba002306cea940.tar.bz2
aports-aaf7501518d7db71e8bdb626dfba002306cea940.tar.xz
testing/xen: patch for busybox sed
So we don't need GNU sed. Discussed on busybox mailing list: http://lists.busybox.net/pipermail/busybox/2012-January/077160.html enable parallell build of xen while there.
Diffstat (limited to 'testing/xen')
-rw-r--r--testing/xen/APKBUILD8
-rw-r--r--testing/xen/busybox-sed.patch11
2 files changed, 16 insertions, 3 deletions
diff --git a/testing/xen/APKBUILD b/testing/xen/APKBUILD
index 30d844d507..d92bebf7c1 100644
--- a/testing/xen/APKBUILD
+++ b/testing/xen/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=xen
pkgver=4.1.2
-pkgrel=0
+pkgrel=1
pkgdesc="Xen hypervisor"
url="http://www.xen.org"
arch="x86 x86_64"
license="GPL"
depends="udev syslinux bash"
depends_dev="openssl-dev python-dev e2fsprogs-dev gettext zlib-dev ncurses-dev
- libiconv-dev dev86 texinfo perl iasl sed pciutils-dev"
+ libiconv-dev dev86 texinfo perl iasl pciutils-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
@@ -22,6 +22,7 @@ source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.g
define_fsimage_dir.patch
pygrub_alpine.patch
librt.patch
+ busybox-sed.patch
xencommons.initd
xend.initd
xendomains.initd"
@@ -56,7 +57,7 @@ build() {
(cd tools/check; ./chk build) || return 1
msg "Building hypervisor..."
- make -j1 xen || return 1
+ make xen || return 1
msg "Building tools..."
make tools || return 1
@@ -88,6 +89,7 @@ b973dc1ffcc6872e222b36f3b7b4836b fix_bswap_blktap2.patch
0bb8a435020a5a49b38b1a447fb69977 define_fsimage_dir.patch
f64405982218db306c2b5cf3167ff944 pygrub_alpine.patch
fa06495a175571f4aa3b6cb88937953e librt.patch
+1bea3543ddc712330527b62fd9ff6520 busybox-sed.patch
4cf88b53f8ca8d99ad52bae419b620a7 xencommons.initd
b5bfc08b82bc0d21193714719a719798 xend.initd
86e7923383a906404da321d1814657e9 xendomains.initd"
diff --git a/testing/xen/busybox-sed.patch b/testing/xen/busybox-sed.patch
new file mode 100644
index 0000000000..e1a9531577
--- /dev/null
+++ b/testing/xen/busybox-sed.patch
@@ -0,0 +1,11 @@
+--- ./xen/arch/x86/boot/Makefile.orig
++++ ./xen/arch/x86/boot/Makefile
+@@ -2,7 +2,7 @@
+
+ head.o: reloc.S
+
+-BOOT_TRAMPOLINE := $(shell sed -n 's,^\#define[[:space:]]\{1\,\}BOOT_TRAMPOLINE[[:space:]]\{1\,\},,p' $(BASEDIR)/include/asm-x86/config.h)
++BOOT_TRAMPOLINE := $(shell sed -n 's,^\#define[[:space:]]\+BOOT_TRAMPOLINE[[:space:]]\+,,p' $(BASEDIR)/include/asm-x86/config.h)
+ %.S: %.c
+ RELOC=$(BOOT_TRAMPOLINE) $(MAKE) -f build32.mk $@
+