aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xload
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2017-04-11 05:59:30 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-13 08:12:37 +0000
commit71e8e056ea8d6bb86daef9ea359ae6b640a93f40 (patch)
treebbcdcb2547c795043288b0fac57db25554dfbf60 /testing/xload
parent040056b3d6672010583b414414b5ec55dc2769f1 (diff)
downloadaports-71e8e056ea8d6bb86daef9ea359ae6b640a93f40.tar.bz2
aports-71e8e056ea8d6bb86daef9ea359ae6b640a93f40.tar.xz
testing/xload: new aport
https://xorg.freedesktop.org/ System load average display for X
Diffstat (limited to 'testing/xload')
-rw-r--r--testing/xload/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/xload/APKBUILD b/testing/xload/APKBUILD
new file mode 100644
index 0000000000..22bd496f1b
--- /dev/null
+++ b/testing/xload/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=xload
+pkgver="1.1.2"
+pkgrel=0
+pkgdesc="System load average display for X"
+url="https://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+depends="libintl"
+makedepends="libx11-dev libxaw-dev libxmu-dev libxt-dev gettext-dev"
+subpackages="$pkgname-doc"
+source="https://xorg.freedesktop.org/archive/individual/app/${pkgname}-${pkgver}.tar.bz2"
+options="!check"
+
+build() {
+ export CFLAGS="$CFLAGS -DRLOADSTUB"
+ export LIBS="$LIBS -lintl"
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-nls
+ make
+}
+
+check(){
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9c83d26bbb135cc0f2b3ef7f25b081cda5d080dd02b1c89195b40825a7d71211965b34336c853eb455472d9748f3edf64108455584b34b81673e2548806f423d xload-1.1.2.tar.bz2"