aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ykpers
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-02 16:47:24 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-02 16:47:54 +0100
commitdb34bf46f114128e9b624e06cf08c145c7747dc2 (patch)
tree786ab421bd0f99db7d9a49e44e274823df74ba96 /testing/ykpers
parent0a8794909b881b2f7ccbcf7bef2c49526317c6eb (diff)
downloadaports-db34bf46f114128e9b624e06cf08c145c7747dc2.tar.bz2
aports-db34bf46f114128e9b624e06cf08c145c7747dc2.tar.xz
testing/ykpers: new aport
https://developers.yubico.com/yubikey-personalization/ YubiKey Personalization library and tool
Diffstat (limited to 'testing/ykpers')
-rw-r--r--testing/ykpers/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/ykpers/APKBUILD b/testing/ykpers/APKBUILD
new file mode 100644
index 0000000000..8805c1c36a
--- /dev/null
+++ b/testing/ykpers/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ykpers
+pkgver=1.18.1
+pkgrel=0
+pkgdesc="YubiKey Personalization library and tool"
+url="https://developers.yubico.com/yubikey-personalization/"
+arch="all"
+license="BSD-2-Clause"
+makedepends="libusb-dev yubico-c-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://developers.yubico.com/yubikey-personalization/Releases/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-udevrulesdir=/usr/lib/udev/rules.d \
+ --with-backend=libusb-1.0
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check CFLAGS="$CFLAGS -D__GLIBC__"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8bed7b3089ac64f8be19717e29a237d40ed17eb5d119630405efd1e269d1b967394c45a349d3290056504a71bf30e2f4e56a0e71d0cd611bd3152080173b652c ykpers-1.18.1.tar.gz"