aboutsummaryrefslogtreecommitdiffstats
path: root/testing/yodl
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-05-06 02:51:21 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-05-06 14:55:39 +0200
commitc01724f27449aabc93e5231f10bcba5a7e9b06f2 (patch)
treece3545d2379c24e6d620923e87449a637e91ae04 /testing/yodl
parent0728c2c6b4728d08d4c0fed741ef5b99c35194bd (diff)
downloadaports-c01724f27449aabc93e5231f10bcba5a7e9b06f2.tar.bz2
aports-c01724f27449aabc93e5231f10bcba5a7e9b06f2.tar.xz
testing/yodl: new aport
https://fbb-git.github.io/yodl/ a pre-document language and tools to process it
Diffstat (limited to 'testing/yodl')
-rw-r--r--testing/yodl/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/yodl/APKBUILD b/testing/yodl/APKBUILD
new file mode 100644
index 0000000000..477977d8aa
--- /dev/null
+++ b/testing/yodl/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Shiz <hi@shiz.me>
+# Maintainer: Shiz <hi@shiz.me>
+pkgname=yodl
+pkgver=3.08.02
+pkgrel=0
+pkgdesc="Pre-document language and tools to process it"
+url="https://fbb-git.github.io/yodl/"
+arch="all"
+license="GPL2"
+makedepends="icmake bash perl flex bison"
+subpackages="$pkgname-doc"
+source="yodl-$pkgver.tar.gz::https://github.com/fbb-git/yodl/archive/$pkgver.tar.gz"
+builddir="$srcdir/yodl-$pkgver/yodl"
+
+prepare() {
+ cd "$builddir"
+ sed -i 's!DOCDOC\s*=.*$!DOCDOC = BASE + "/share/doc/yodl";!g' INSTALL.im
+}
+
+build() {
+ cd "$builddir"
+ local module; for module in programs macros man; do
+ ./build $module
+ done
+}
+
+check() {
+ cd "$builddir"
+ # yodl likes to exit with a non-zero exit status with --version.
+ ./tmp/install/usr/bin/yodl --version | grep -q 'yodl version'
+}
+
+package() {
+ cd "$builddir"
+ local module; for module in programs macros man; do
+ ./build install $module "$pkgdir"
+ done
+}
+
+sha512sums="adad9f6235288f0ae6990c0dbba3cd7c8461172ae83231ca8fa113275d04ad20d3722e70f6f0ffcf072a19b4816e556b9b09227123516fc4a0170bc053b48b8e yodl-3.08.02.tar.gz"