aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zim
diff options
context:
space:
mode:
author_spOOn_ <adam@spoontech.biz>2017-05-29 00:33:51 +0930
committerShiz <hi@shiz.me>2017-06-02 11:04:24 +0200
commit362127bbcc098d59cb9c75c257d708ce716c7f5c (patch)
treec7545bae36e1aeae9009276d23bc600f94ca7889 /testing/zim
parent7fc7e98817fc3ecaf08eea068202caf3ce301acf (diff)
downloadaports-362127bbcc098d59cb9c75c257d708ce716c7f5c.tar.bz2
aports-362127bbcc098d59cb9c75c257d708ce716c7f5c.tar.xz
testing/zim: new aport
http://zim-wiki.org/ A Desktop Wiki Editor - Removed commented/blank variables - Added Maintainer - Changed URL to use variables instead of hardcoded path - Added desktop-file-utils to makedepends as it was required at build time Thanks Shizmob for your help :)
Diffstat (limited to 'testing/zim')
-rw-r--r--testing/zim/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/zim/APKBUILD b/testing/zim/APKBUILD
new file mode 100644
index 0000000000..7b3a1c0b23
--- /dev/null
+++ b/testing/zim/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Adam Nye <adam@spoontech.biz>
+# Maintainer: Adam Nye <adam@spoontech.biz>
+pkgname=zim
+pkgver=0.66
+pkgrel=0
+pkgdesc="A Desktop Wiki Editor"
+url="http://zim-wiki.org/"
+arch="all"
+license="GPL2"
+depends="python py-gobject py-xdg py-gtk py-simplejson xdg-utils"
+makedepends="desktop-file-utils"
+subpackages="$pkgname-doc"
+source="http://zim-wiki.org/downloads/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9693dba8ee6ad915a85ca999674350b278043559ba4adf93c03c8815211ecab451a6e2dceaf62ea7048609eb86f19485f2dd77dbaaf6f2d81f97f6450bf25ca9 zim-0.66.tar.gz"