aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-06-15 22:23:15 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-06-15 23:24:12 +0200
commit012027fcceafd5dfaaf76b7f09cdf3653c12e01e (patch)
tree5e859cf3510234b651de9071cb5e43aa84177106 /testing
parent70e467bd9703c3a7b9969826179106c668348bd3 (diff)
downloadaports-012027fcceafd5dfaaf76b7f09cdf3653c12e01e.tar.bz2
aports-012027fcceafd5dfaaf76b7f09cdf3653c12e01e.tar.xz
testing/vboot-utils: new aports
Diffstat (limited to 'testing')
-rw-r--r--testing/vboot-utils/0001-Remove-static-futility.patch38
-rw-r--r--testing/vboot-utils/APKBUILD45
2 files changed, 83 insertions, 0 deletions
diff --git a/testing/vboot-utils/0001-Remove-static-futility.patch b/testing/vboot-utils/0001-Remove-static-futility.patch
new file mode 100644
index 0000000000..cae6b3a847
--- /dev/null
+++ b/testing/vboot-utils/0001-Remove-static-futility.patch
@@ -0,0 +1,38 @@
+From 59166c9aacda115ea2feb2e3f6a01c23f5e91fc2 Mon Sep 17 00:00:00 2001
+From: Kevin Mihelich <kevin@archlinuxarm.org>
+Date: Sun, 18 Mar 2018 14:46:01 -0600
+Subject: [PATCH] Remove static futility
+
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1f3e7f664..75168b146 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1112,7 +1112,7 @@ signing_install: ${SIGNING_SCRIPTS} ${SIGNING_SCRIPTS_DEV} ${SIGNING_COMMON}
+ # new Firmware Utility
+
+ .PHONY: futil
+-futil: ${FUTIL_STATIC_BIN} ${FUTIL_BIN}
++futil: ${FUTIL_BIN}
+
+ ${FUTIL_STATIC_BIN}: LDLIBS += ${CRYPTO_STATIC_LIBS} -lpthread
+ ${FUTIL_STATIC_BIN}: ${FUTIL_STATIC_OBJS} ${UTILLIB}
+@@ -1125,10 +1125,10 @@ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
+ ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} $^ ${LDLIBS}
+
+ .PHONY: futil_install
+-futil_install: ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
++futil_install: ${FUTIL_BIN}
+ @${PRINTF} " INSTALL futility\n"
+ ${Q}mkdir -p ${UB_DIR}
+- ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
++ ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN}
+ ${Q}for prog in ${FUTIL_SYMLINKS}; do \
+ ln -sf futility "${UB_DIR}/$$prog"; done
+
+--
+2.16.2
+
diff --git a/testing/vboot-utils/APKBUILD b/testing/vboot-utils/APKBUILD
new file mode 100644
index 0000000000..797d603532
--- /dev/null
+++ b/testing/vboot-utils/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=vboot-utils
+pkgver=6310032
+pkgrel=0
+pkgdesc="Chromium OS vboot utilities"
+url="https://github.com/coreboot/vboot"
+arch="all !ppc64le !s390x"
+license="custom:chromiumos"
+makedepends="yaml-dev xz-dev fts-dev openssl-dev util-linux-dev bash linux-headers"
+subpackages="cgpt $pkgname-doc"
+source="http://cdn-fastly.deb.debian.org/debian/pool/main/v/vboot-utils/vboot-utils_0~R63-10032.B.orig.tar.gz
+ 0001-Remove-static-futility.patch"
+builddir="$srcdir"
+
+prepare() {
+ sed -i 's/-Werror//g' Makefile
+}
+
+build() {
+ cd "$builddir"
+ case "$CARCH" in
+ arm*|aarch64) ARCH=arm make V=1 ;;
+ esac
+ make V=1
+}
+
+check() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir"/usr install
+ mkdir -p "$pkgdir"/usr/share/doc
+ cp LICENSE "$pkgdir"/usr/share/doc
+}
+
+cgpt() {
+ pkgdesc="ChromeOS GPT tool"
+ mkdir -p "$subpkgdir"/usr/sbin
+ mv "$pkgdir"/usr/bin/cgpt "$subpkgdir"/usr/sbin/
+}
+sha512sums="48c0cf858f74cbb0020212ac619ed93ac011530e4f25518e05301f710bb78eba532ee901e79a04d6808122ef589fdf4c6a0f53656350d2f9bf717c588fc795fc vboot-utils_0~R63-10032.B.orig.tar.gz
+baaa5c262352d76542cd1012fa66ce75a1251430181cf0063316a3a632dc248539a619ebd4d5da546281170dd944f256682502399cc6b367057c2167a486bebf 0001-Remove-static-futility.patch"