aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-05-12 07:17:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-05-12 07:17:05 +0000
commit03c48cd02095c9eaa1703e6fb1323ff40429a722 (patch)
tree9abe6728c4735d670ba32a0c80a89d24ba6654a1 /testing
parent2b5ce5be5540d6172f5d2ad42d7754b96d6560fb (diff)
downloadaports-03c48cd02095c9eaa1703e6fb1323ff40429a722.tar.bz2
aports-03c48cd02095c9eaa1703e6fb1323ff40429a722.tar.xz
testing/py3-yara: upgrade to 4.0.0
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-yara/APKBUILD8
-rw-r--r--testing/py3-yara/use-system-yara.patch9
2 files changed, 14 insertions, 3 deletions
diff --git a/testing/py3-yara/APKBUILD b/testing/py3-yara/APKBUILD
index 262abef17a..0a98286978 100644
--- a/testing/py3-yara/APKBUILD
+++ b/testing/py3-yara/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname="py3-yara"
_pkgname="${pkgname/py3-/}-python"
-pkgver="3.11.0"
+pkgver=4.0.0
pkgrel=0
pkgdesc="The Python interface for YARA"
url="https://virustotal.github.io/yara/"
@@ -10,7 +10,8 @@ arch="all !ppc64le !armv7 !armhf" # missing yara
license="Apache-2.0"
depends="python3"
makedepends="python3-dev yara py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/yara-python/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/yara-python/archive/v$pkgver.tar.gz
+ use-system-yara.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -25,4 +26,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0c8e6cbe51aa858c6d56b95c88bd450016924008b57b4910ed8edfb7bba4d7bfc18736844817978f74e72bed6765c484f275de4e7a53ec85048fb01713b6e959 py3-yara-3.11.0.tar.gz"
+sha512sums="9210793d305e34313494e3d867fc3a729814401208206a0f6f7fd2bfdcb6482a8e19e64788c35c149cd5a65cdc5357d8fa1e020fae6ac8c2704fa55e6c2cb989 py3-yara-4.0.0.tar.gz
+d56d2c437f66b0d3c5bc92737f6b5c7bf5191e38fe4f72849145dbcbc2eb7d9cad10a2d07674c25aaa1e7f542b21e723c30722516e722db5c238840e4f6be07a use-system-yara.patch"
diff --git a/testing/py3-yara/use-system-yara.patch b/testing/py3-yara/use-system-yara.patch
new file mode 100644
index 0000000000..d7a0f8e7ce
--- /dev/null
+++ b/testing/py3-yara/use-system-yara.patch
@@ -0,0 +1,9 @@
+--- a/setup.py.orig 2019-05-02 17:34:46.000000000 +0800
++++ b/setup.py 2019-05-07 08:20:20.841022106 +0800
+@@ -325,5 +325,5 @@
+ 'update': UpdateCommand},
+ ext_modules=[Extension(
+ name='yara',
+- include_dirs=['yara/libyara/include', 'yara/libyara/', '.'],
++ libraries = ['yara'],
+ sources=['yara-python.c'])])