aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-25 17:56:31 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 13:30:41 -0300
commit056a98378f3b63287dc8e13cd06a11a5f2aa4884 (patch)
tree60228f625b5b502db7ae85c185951f49a08f2f27 /testing
parent9729afd8c0f61b254008400a416a15c310571c69 (diff)
downloadaports-056a98378f3b63287dc8e13cd06a11a5f2aa4884.tar.bz2
aports-056a98378f3b63287dc8e13cd06a11a5f2aa4884.tar.xz
testing/kio-extras: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/kio-extras/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/kio-extras/APKBUILD b/testing/kio-extras/APKBUILD
new file mode 100644
index 0000000000..762aad206c
--- /dev/null
+++ b/testing/kio-extras/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kio-extras
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/internet/"
+pkgdesc="Additional components to increase the functionality of KIO"
+license="GPL-2.0-or-later (LGPL-2.1-only OR LGPL-3.0-only)"
+depends="kinit"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdoctools-dev kdnssd-dev kiconthemes-dev ki18n-dev kio-dev solid-dev kbookmarks-dev kguiaddons-dev syntax-highlighting-dev kpty-dev kactivities-dev phonon-dev samba-dev libssh-dev libmtp-dev gperf khtml-dev shared-mime-info nfs-utils-dev"
+checkdepends="xvfb-run kinit"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # Requires running dbus-server
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="641048ec00585dde1ce8bb897647d4c4abe451f54d3024be5d7ffa5184243a97bacffe14d842b865aaf39a15fce13a9379a7e494c6f7e50911e4794fc7b52a16 kio-extras-19.04.2.tar.xz"