aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCorentin Henry <corentinhenry@gmail.com>2016-06-03 11:30:37 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-06-03 16:15:31 +0200
commit0693cd94e453ec1bfb5b27c8fa229a9a40f41b69 (patch)
treec064d47aaaafef96b071e7555dacf16497a65aa0 /testing
parentae7182192a11d96a5318abc74f8143fd1171c6de (diff)
downloadaports-0693cd94e453ec1bfb5b27c8fa229a9a40f41b69.tar.bz2
aports-0693cd94e453ec1bfb5b27c8fa229a9a40f41b69.tar.xz
testing/py-google-apputils: upgrade to 0.4.2
Diffstat (limited to 'testing')
-rw-r--r--testing/py-google-apputils/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/testing/py-google-apputils/APKBUILD b/testing/py-google-apputils/APKBUILD
index c7f36f4e7b..575a4a4c84 100644
--- a/testing/py-google-apputils/APKBUILD
+++ b/testing/py-google-apputils/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Corentin Henry <corentinhenry@gmail.com>
# Maintainer: Corentin Henry <corentinhenry@gmail.com>
pkgname=py-google-apputils
-_pkgname=google-apputils
-pkgver=0.4.0
+_pkgname=${pkgname#py-}
+pkgver=0.4.2
pkgrel=0
pkgdesc="Google Application Utilities for Python"
url="https://github.com/google/google-apputils"
@@ -22,8 +22,14 @@ build() {
package() {
cd "$builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+
+ # Workaround for https://github.com/google/google-apputils/issues/4.
+ # The files under google_apputils.egg-info lack read permission for
+ # "other", which causes `python setup.py build` failures for packages
+ # using google-apputils.
+ chmod o+r "$pkgdir"/usr/lib/python2.7/site-packages/$_pkgname-$pkgver-py2.7.egg-info/*
}
-md5sums="59e19f16b9a1adb2c84987581ee8b659 google-apputils-0.4.0.tar.gz"
-sha256sums="b260eb39f2723b71329ad016773033b95a31e89d8c9e13b8e6a1ef8eed8e94a3 google-apputils-0.4.0.tar.gz"
-sha512sums="5dbbf50e9551b33d882557ef9385c64691dcff6d6c219c9ff6aea2dc73c8af6d03392b3088fe1fb4000979e227830a0e437dc347520488627657085c8ea23f5e google-apputils-0.4.0.tar.gz"
+md5sums="fb9fadf621dbecf28c8dabb5fe37ddb3 google-apputils-0.4.2.tar.gz"
+sha256sums="47959d0651c32102c10ad919b8a0ffe0ae85f44b8457ddcf2bdc0358fb03dc29 google-apputils-0.4.2.tar.gz"
+sha512sums="d7579ec461292bb01ad5b8e1b09e161c66af0e85361f43f6065b837c90bddb9711a2d56db2b73d780dc25945375d4dad2f646507512b9acfeefd517613feacd4 google-apputils-0.4.2.tar.gz"