aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-11-26 21:34:24 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:37 -0500
commit0727f73c57b390c8eee90276afbf3d5a9045fb12 (patch)
treef24f70d7e601f511d2a7c1e68abe820c419ffd58 /testing
parent93415221b8ac0ec73382e350c0c90a8e80af25a9 (diff)
downloadaports-0727f73c57b390c8eee90276afbf3d5a9045fb12.tar.bz2
aports-0727f73c57b390c8eee90276afbf3d5a9045fb12.tar.xz
testing/perl-io-async: new APKBUILD
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-io-async/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-io-async/APKBUILD b/testing/perl-io-async/APKBUILD
new file mode 100644
index 0000000000..a5e6d15416
--- /dev/null
+++ b/testing/perl-io-async/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-io-async
+_pkgreal=IO-Async
+pkgver=0.45
+pkgrel=0
+pkgdesc="Asynchronous event-driven programming"
+url="http://search.cpan.org/dist/IO-Async/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-heap perl-async-mergepoint perl-cps"
+cpanmakedepends="perl-test-fatal perl-test-warn perl-test-refcount perl-test-identity"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="00f4213a413bb1fc431bfe56568c0192 IO-Async-0.45.tar.gz"