aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 10:34:22 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-23 18:33:37 +0000
commit07ecf28d13e87f39618e000467e3a428110f5da3 (patch)
treed49c6c9aba4a213bcfe9c20fcbd770a225161abf /testing
parent719985c8c8ee4a331428307d2a9c1bda2d5680f0 (diff)
downloadaports-07ecf28d13e87f39618e000467e3a428110f5da3.tar.bz2
aports-07ecf28d13e87f39618e000467e3a428110f5da3.tar.xz
testing/wifish: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/wifish/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/wifish/APKBUILD b/testing/wifish/APKBUILD
new file mode 100644
index 0000000000..bd24d4734f
--- /dev/null
+++ b/testing/wifish/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=wifish
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Simple wifi menu tool for wpa_supplicant"
+url="http://github.com/bougyman/wifish"
+options="!check" # Tests require running wpa_supplicant instance with wpa_cli
+arch="noarch"
+license="WTFPL"
+depends="wpa_supplicant gawk dialog"
+checkdepends="gawk checkbashisms"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bougyman/wifish/archive/${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ install -Dm777 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd awk
+ for awk in *; do
+ install -Dm644 "$awk" "$pkgdir"/var/lib/wifish/"$awk"
+ done
+}
+
+sha512sums="5315ff3449a5e5162422997ec43946d1f4c441ba436484ae485ba3d6bd3d53f207ddd3d569112b2f1e8eb30f965f80aa5d651f2d07c031d140678274b22beced wifish-1.1.4.tar.gz"