aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-07-06 09:20:19 +0000
committerBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-06 13:36:09 +0200
commit0bc9aa6ced4592eb4d26353d714dae0f3dfd4df8 (patch)
tree7b7ba7befc367e167c63ee5184ef0e5d9b7ee8d3 /testing
parent80184bbe42a9ba56800ca40b6695b33bf98ad043 (diff)
downloadaports-0bc9aa6ced4592eb4d26353d714dae0f3dfd4df8.tar.bz2
aports-0bc9aa6ced4592eb4d26353d714dae0f3dfd4df8.tar.xz
testing/opencpn: new aport
OpenCPN is a cross platform electronic navigation system. http://opencpn.org
Diffstat (limited to 'testing')
-rw-r--r--testing/opencpn/APKBUILD40
-rw-r--r--testing/opencpn/CMakeList.txt.patch13
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/opencpn/APKBUILD b/testing/opencpn/APKBUILD
new file mode 100644
index 0000000000..db6d4bb385
--- /dev/null
+++ b/testing/opencpn/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=opencpn
+pkgver=4.4.0
+pkgrel=0
+pkgdesc="OpenCPN is a cross platform electronic navigation system"
+url="http://opencpn.org"
+arch="x86 x86_64"
+license="GPL2"
+depends=""
+makedepends="wxgtk-dev libexecinfo-dev linux-headers curl-dev cmake gpsd
+ portaudio-dev tinyxml-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/v${pkgver}.tar.gz
+CMakeList.txt.patch"
+
+builddir="$srcdir/OpenCPN-${pkgver}"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUNDLE_GSHHS=CRUDE \
+ -DBUNDLE_TCDATA=ON \
+ -DBUNDLE_DOCS=ON || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d991b49373c45f9756fa79c3b3a0f215 opencpn-4.4.0.tar.gz
+ed2a9317525fd5e06c3e51e582d86e40 CMakeList.txt.patch"
+sha256sums="577ae0fa44d31840e268b22c50b78130695fdfc796420514c93b238d5bde39b9 opencpn-4.4.0.tar.gz
+2f653299f09312c4218febf66855c1b56d8b0278163e3dd5868bf28b725b4df0 CMakeList.txt.patch"
+sha512sums="ebe4c3518d2addbbba36cec78719cb1c853969923e7ade4f6df78a8520224fef9f421b809f573cfa770acc9b9d31a90341d6114edc02a307682d0fca5c62b26b opencpn-4.4.0.tar.gz
+79daf622a5a9a54db81a09bc1004819bb4d20ce2959a4d3204e8ff09d4669e55ebb85b37961397cc6c8a00b87e081126685c51f6bdb78d9d324ce4f7c8b2f2ef CMakeList.txt.patch"
diff --git a/testing/opencpn/CMakeList.txt.patch b/testing/opencpn/CMakeList.txt.patch
new file mode 100644
index 0000000000..8a1341d424
--- /dev/null
+++ b/testing/opencpn/CMakeList.txt.patch
@@ -0,0 +1,13 @@
+index 967e558..27bad69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -489,6 +489,9 @@ IF(OCPN_USE_CRASHREPORT)
+ IF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ MESSAGE (STATUS "Using Linux crash reporting")
+ ADD_DEFINITIONS(-DLINUX_CRASHRPT)
++ IF(EXISTS /etc/alpine-release)
++ SET(EXTRA_LIBS ${EXTRA_LIBS} "execinfo")
++ ENDIF(EXISTS alpine-release)
+ ENDIF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ ENDIF(NOT APPLE AND NOT QT_ANDROID AND NOT MINGW)
+ ENDIF(MSVC