aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-14 13:09:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-14 13:10:42 +0000
commit0d940c92f473a294d6b15e2bf74b3ba92af70b54 (patch)
tree34ee54334e429074175a079cfca1e2d1580e4d37 /testing
parenta38596fdac13672f38b77fce9276ab9fbcc31706 (diff)
downloadaports-0d940c92f473a294d6b15e2bf74b3ba92af70b54.tar.bz2
aports-0d940c92f473a294d6b15e2bf74b3ba92af70b54.tar.xz
testing/py3-intervals: fix tests
patch from Arch Linux. Thanks!
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-intervals/APKBUILD8
-rw-r--r--testing/py3-intervals/pytest5.patch21
2 files changed, 26 insertions, 3 deletions
diff --git a/testing/py3-intervals/APKBUILD b/testing/py3-intervals/APKBUILD
index 85b14922b2..f6b70c9ca0 100644
--- a/testing/py3-intervals/APKBUILD
+++ b/testing/py3-intervals/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-intervals
_pkgname=intervals
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Python module for handling intervals (ranges of comparable objects)"
url="https://github.com/kvesteri/intervals"
arch="noarch"
@@ -11,7 +11,8 @@ license="BSD-3-Clause"
depends="py3-infinity"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest5.patch"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-intervals" # Backwards compatibility
@@ -29,4 +30,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="f97142d5f1c8d4da21692b856803481878ac2b2afc3b81937de456bacbf66ebb129b1fe9a070ac442cbc6bbe26fdaf2ed839f8fc8b26392b4bd1ce032d054e65 intervals-0.8.1.tar.gz"
+sha512sums="f97142d5f1c8d4da21692b856803481878ac2b2afc3b81937de456bacbf66ebb129b1fe9a070ac442cbc6bbe26fdaf2ed839f8fc8b26392b4bd1ce032d054e65 intervals-0.8.1.tar.gz
+af545bec7d8157259197e045396d69ac1791b5e0420056fca69bea444cceacaa208ae568fd80792f614e1c775611ea22c48521bdd47dbdd976a699c150835f96 pytest5.patch"
diff --git a/testing/py3-intervals/pytest5.patch b/testing/py3-intervals/pytest5.patch
new file mode 100644
index 0000000000..24b9f502d4
--- /dev/null
+++ b/testing/py3-intervals/pytest5.patch
@@ -0,0 +1,21 @@
+diff -upr intervals-0.8.1.orig/tests/interval/test_initialization.py intervals-0.8.1/tests/interval/test_initialization.py
+--- intervals-0.8.1.orig/tests/interval/test_initialization.py 2016-07-10 21:14:03.000000000 +0300
++++ intervals-0.8.1/tests/interval/test_initialization.py 2019-11-01 17:26:19.862962549 +0200
+@@ -23,7 +23,7 @@ class TestIntervalInit(object):
+ 'First argument should be a list or tuple. If you wish to '
+ 'initialize an interval from string, use from_string factory '
+ 'method.'
+- ) in str(e)
++ ) in str(e.value)
+
+ def test_invalid_argument(self):
+ with raises(IllegalArgument) as e:
+@@ -31,7 +31,7 @@ class TestIntervalInit(object):
+ assert (
+ 'The bounds may be equal only if at least one of the bounds is '
+ 'closed.'
+- ) in str(e)
++ ) in str(e.value)
+
+ def test_floats(self):
+ interval = FloatInterval((0.2, 0.5))