aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-22 00:33:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-22 14:47:55 -0300
commit0ede9e29f44da2c462a486d3a5860f90f814d012 (patch)
tree6c78cf137e6361a0390ad651a0751d4dad1c2701 /testing
parent15a7e25a54d20fea11311808980b2bb00f1a1079 (diff)
downloadaports-0ede9e29f44da2c462a486d3a5860f90f814d012.tar.bz2
aports-0ede9e29f44da2c462a486d3a5860f90f814d012.tar.xz
testing/mycli: upgrade to 1.20.1
Diffstat (limited to 'testing')
-rw-r--r--testing/mycli/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/testing/mycli/APKBUILD b/testing/mycli/APKBUILD
index 425b547142..ccdeafa49d 100644
--- a/testing/mycli/APKBUILD
+++ b/testing/mycli/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=mycli
-pkgver=1.20.0
+pkgver=1.20.1
pkgrel=0
pkgdesc="MySQL CLI with autocompletion and syntax highlighting"
url="https://www.mycli.net"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
options="!check" # builders /dev/tty not accessible
depends="python3
py3-click
@@ -18,24 +18,20 @@ depends="python3
py3-cryptography
py3-cli_helpers"
makedepends="python3-dev py3-setuptools"
-checkdepends="pytest py3-mock"
+checkdepends="py3-pytest py3-mock"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
"
-builddir="$srcdir/$pkgname-$pkgver"
check() {
- cd "$builddir"
python3 -m pytest test
}
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="fbed2eed34fd8df0105c4c9975545f613d1318195f810e723d4f8cf0144d3c52c55b7acb512d76d41ba908a7b17d638451eb71d06c94065a58f0e95bf7caf905 mycli-1.20.0.tar.gz"
+sha512sums="9b25136b02f6147b84fb39f3baa315aa79b735facdabe35dfb049f171491b3a2e7166797ebcfe637e9e4de31675334ac66bdcea9cdd3cbc145f072d676c19c0c mycli-1.20.1.tar.gz"