aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 22:02:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commit11349d541e943f684d93748af26991a0f1ea4356 (patch)
treea277757f960ae0f355c32dc651ad805569472e78 /testing
parent7186d945c6e100a3b9558c191f041fc7539f2a1d (diff)
downloadaports-11349d541e943f684d93748af26991a0f1ea4356.tar.bz2
aports-11349d541e943f684d93748af26991a0f1ea4356.tar.xz
testing/py-lockfile: new aport
A Python file locking module https://github.com/smontanaro/pylockfile
Diffstat (limited to 'testing')
-rw-r--r--testing/py-lockfile/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-lockfile/APKBUILD b/testing/py-lockfile/APKBUILD
new file mode 100644
index 0000000000..1aedd915a4
--- /dev/null
+++ b/testing/py-lockfile/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-lockfile
+_pkgname=lockfile
+pkgver=0.9.1
+pkgrel=0
+pkgdesc="A Python file locking module"
+url="https://github.com/smontanaro/pylockfile"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ce61468d4c1263e3005737bbed2641f0 lockfile-0.9.1.tar.gz"
+sha256sums="23da589c91f59cb7c644d5ce5df539d448341bd479917d6dde973f82e2719147 lockfile-0.9.1.tar.gz"
+sha512sums="46288cb4d15bcb546d6cece7e032b7b020c71fba695d16a3c7718eeb0bc15c97c29f09f3c1649b6061d117e6bbd708e243fdcee89b2fa5f13a262a0e74f62c3d lockfile-0.9.1.tar.gz"