aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-04 10:25:23 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-04 10:25:35 +0000
commit14f0993f7f6e3df19131c0034ecea7052af2add4 (patch)
tree83fabcb454ab4f3b91fc6313c08bbf134844e814 /testing
parent3fdd87f978d89ddc63dddd7fae965039387f4f1a (diff)
downloadaports-14f0993f7f6e3df19131c0034ecea7052af2add4.tar.bz2
aports-14f0993f7f6e3df19131c0034ecea7052af2add4.tar.xz
testing/nextcloud-client: new aport
WebDAV syncronization client for Nextcloud
Diffstat (limited to 'testing')
-rw-r--r--testing/nextcloud-client/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/nextcloud-client/APKBUILD b/testing/nextcloud-client/APKBUILD
new file mode 100644
index 0000000000..1c57b390fd
--- /dev/null
+++ b/testing/nextcloud-client/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=nextcloud-client
+_realname=client_theming
+pkgver=2.2.4
+pkgrel=0
+pkgdesc="Nextcloud Desktop Client"
+url="https://github.com/nextcloud/client_theming"
+arch="all"
+license="GPL2"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake qt5-qttools-dev qt5-qtwebkit-dev
+ qt5-qtkeychain-dev"
+install=
+subpackages="$pkgname-dev"
+source="owncloud-client-$pkgver.tar.gz::https://github.com/owncloud/client/archive/v$pkgver.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/nextcloud/$_realname/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/client-$pkgver
+
+build() {
+ cd "$builddir"
+ # mkdir _build.tmp && cd _build.tmp
+ cmake \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/$pkgname \
+ -DOEM_THEME_DIR="$srcdir/$_realname-$pkgver/nextcloudtheme"
+ make all || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="144022a1773df0c4a25686a043bf4b1f owncloud-client-2.2.4.tar.gz
+6d612c661f90e5ce1e0791520ecd6df3 nextcloud-client-2.2.4.tar.gz"
+sha256sums="416e8a003ba95387cb5e22fac909c2c2ee21765de413a26397027d36ad89e39b owncloud-client-2.2.4.tar.gz
+55a16505c8551cb8e6af5d2f570b6d4384f33a75a79810864e1d4555d53dedf9 nextcloud-client-2.2.4.tar.gz"
+sha512sums="95de459bf818201d92b55ea0e4a0c2f6aa8f8d5fd57de2c937b7679bfafd4f98e64a793b00bbc5654da36c06a8c78f8f85aad449b5190b82d8a7f529f8714018 owncloud-client-2.2.4.tar.gz
+646e624335cc11ac862b1b58ceb36aa8264f2db6ed586ae473b7522a5fdab7e30f196c1680f8dcf70af3b204374488e3bd589bb41669f9abcd9509d2293afc3f nextcloud-client-2.2.4.tar.gz"