aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBridouz <justin.berthault@zaclys.net>2020-04-30 19:27:40 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-04-30 19:27:40 +0000
commit19555e27fbe4c382d545355139c277e6785691e6 (patch)
tree0ae398fd555c33e26df53219ffca3cf3358b19a7 /testing
parent76044e31395d2088147cbfcaaceddbad2ffd08c4 (diff)
downloadaports-19555e27fbe4c382d545355139c277e6785691e6.tar.bz2
aports-19555e27fbe4c382d545355139c277e6785691e6.tar.xz
testing/jgmenu: new aport
https://github.com/johanmalm/jgmenu Simple, independent X11 menu
Diffstat (limited to 'testing')
-rw-r--r--testing/jgmenu/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/jgmenu/APKBUILD b/testing/jgmenu/APKBUILD
new file mode 100644
index 0000000000..81ac844667
--- /dev/null
+++ b/testing/jgmenu/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=jgmenu
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="Simple, independent X11 menu"
+url="https://github.com/johanmalm/jgmenu"
+arch="all !s390x" # missing dep: librsvg
+license="GPL-2.0-only"
+depends="
+ bash
+ desktop-file-utils
+ python3
+ "
+makedepends="
+ bash
+ librsvg-dev
+ libxrandr-dev
+ libxml2-dev
+ pango-dev
+ "
+checkdepends="perl"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/johanmalm/jgmenu/archive/v$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="762a83aaa6806205e9e6d211abb7127c077a484d2893dee50c8a9dcb62850a07901c6569a95748b6c2fa7c2ee94a762fee2ba7c9bc37207702c65b571e81d0bc jgmenu-4.1.0.tar.gz"