aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-15 16:03:11 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-16 18:37:49 +0000
commit1b61bb81e9a6a52611369c3e29a4c0fa57c585ce (patch)
treebaf3c927e56e148316321c61a2a23c9bf1e68a61 /testing
parent58fd03f656f94a9c29da35cbf6781e1f37a2fa99 (diff)
downloadaports-1b61bb81e9a6a52611369c3e29a4c0fa57c585ce.tar.bz2
aports-1b61bb81e9a6a52611369c3e29a4c0fa57c585ce.tar.xz
testing/py3-pytest-localserver: new package
Dependency for checking testing/py3-google-auth
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pytest-localserver/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pytest-localserver/APKBUILD b/testing/py3-pytest-localserver/APKBUILD
new file mode 100644
index 0000000000..c37285175b
--- /dev/null
+++ b/testing/py3-pytest-localserver/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-pytest-localserver
+_pyname=pytest-localserver
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="a pytest plugin to test server connections locally"
+url="http://bitbucket.org/pytest-dev/pytest-localserver/"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest py3-six py3-requests py3-werkzeug"
+source="https://files.pythonhosted.org/packages/source/p/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+builddir="${srcdir}/${_pyname}-${pkgver}"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ pytest-3
+}
+
+sha512sums="aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc pytest-localserver-0.5.0.tar.gz"