aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 14:35:57 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 14:36:02 +0000
commit232d305d5788fb032c28b40e812a8d73d8e6004c (patch)
tree3c4b9f1f15623d23970f60a64c6f02fd4ac7039e /testing
parent62565895c0fec101a225f5dff7f910d347b017e0 (diff)
downloadaports-232d305d5788fb032c28b40e812a8d73d8e6004c.tar.bz2
aports-232d305d5788fb032c28b40e812a8d73d8e6004c.tar.xz
testing/guake: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/guake/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/guake/APKBUILD b/testing/guake/APKBUILD
new file mode 100644
index 0000000000..41842d3f38
--- /dev/null
+++ b/testing/guake/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=guake
+pkgver=0.8.9
+pkgrel=0
+pkgdesc="Drop-down terminal for GNOME"
+url="http://guake-project.org"
+arch="all"
+license="GPL"
+depends="py-keybinder"
+makedepends="python3-dev gtk+2.0-dev py-gtk-dev gconf-dev py2-vte
+ autoconf automake libtool m4 gnome-common intltool"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Guake/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+prepare() {
+ cd "$builddir"
+ NOCONFIGURE=1 ./autogen.sh
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-nls \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fecf481fe5940e64b51329e0fdfacfc26083755bc4fbc8358b92fd5c78c5d2ce0bdc65a2af2e9b0679c04d61c4be6cd202179a0c45965c4a71ee82246f53c02c guake-0.8.9.tar.gz"