aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 02:25:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:03:15 -0300
commit26d867b597d5fc1d2d2275a35fb447b509fd26fd (patch)
tree0a018e25cbcb69d91a1f2533fcd1857832c62704 /testing
parentdcd36cc9face2c807e539432cd74a1080dc98af9 (diff)
downloadaports-26d867b597d5fc1d2d2275a35fb447b509fd26fd.tar.bz2
aports-26d867b597d5fc1d2d2275a35fb447b509fd26fd.tar.xz
testing/py3-case: upgrade to 1.5.3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-case/APKBUILD49
1 files changed, 10 insertions, 39 deletions
diff --git a/testing/py3-case/APKBUILD b/testing/py3-case/APKBUILD
index 13dbf88818..9d19cda52a 100644
--- a/testing/py3-case/APKBUILD
+++ b/testing/py3-case/APKBUILD
@@ -1,59 +1,30 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-case
+pkgname=py3-case
_pyname=case
-pkgver=1.5.0
-pkgrel=1
+pkgver=1.5.3
+pkgrel=0
pkgdesc="Python unittest utilities"
url="https://github.com/celery/case/"
arch="noarch"
-license="BSD"
-makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
-checkdepends="
- py2-coverage py3-coverage py2-mock py3-mock py2-nose py3-nose py2-unittest2
-"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+license="BSD-3-Clause"
+makedepends="py3-setuptools"
+checkdepends="py3-coverage py3-mock py3-nose"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
-prepare() {
- cd "$builddir"
- cp -r "$builddir" "$builddir"-py2
-}
+replaces="py-case" # Backwards compatibility
+provides="py-case=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
- cd "$builddir"-py2
- python2 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
- cd "$builddir"-py2
- python2 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- cd "$builddir"-py2
- _py python2
-}
-
-_py3() {
- cd "$builddir"
- _py python3
-}
-
-_py() {
- _python="$1"
- pkgdesc="$pkgdesc (for $_python)"
- depends="$depends $_python"
- install_if="$pkgname=$pkgver-r$pkgrel $_python"
- $_python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0ae03ab175903bc55a81df9c1847587960bec64202be66702456b447c3114d8a9b49fa7bfa08cb032040bc2c1f17411642392abee617e4400fae0a9b67d38702 case-1.5.0.tar.gz"
+sha512sums="ae98a571c282f80c685c42ab1dc578847fe88cf8cd07faff505a8df8e3282a602908a8780ab88b36851e3ee6f3c178405e5c50776fd0f49fcc990087575f2958 case-1.5.3.tar.gz"