aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 23:40:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 02:17:07 -0300
commit2c0858f3ef941a9d37004dd2805a5f417f41bf76 (patch)
treefff1c513833e06b30c116ee1ba28d7c5901649ba /testing
parent259949f90ffb92fdc0a9ebf2492f693c9c61dd82 (diff)
downloadaports-2c0858f3ef941a9d37004dd2805a5f417f41bf76.tar.bz2
aports-2c0858f3ef941a9d37004dd2805a5f417f41bf76.tar.xz
testing/py3-soupsieve: new aport
https://github.com/facelessuser/soupsieve A modern CSS selector implementation for Beautiful Soup
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-soupsieve/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-soupsieve/APKBUILD b/testing/py3-soupsieve/APKBUILD
new file mode 100644
index 0000000000..d1a7502f4c
--- /dev/null
+++ b/testing/py3-soupsieve/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-soupsieve
+pkgver=1.9.3
+pkgrel=0
+pkgdesc="A modern CSS selector implementation for Beautiful Soup"
+options="!check" # Circular dependency on py3-beautifulsoup4
+url="https://github.com/facelessuser/soupsieve"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/facelessuser/soupsieve/archive/$pkgver.tar.gz"
+builddir="$srcdir/soupsieve-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e8db91905aae0532482b6872b47cd600214ecd1a54ec73d7068bf7177e3bd33182e9f6585a5b43350aab8f3bcc412c739ef8eb5b7778e9c44cf53f73254ec06a py3-soupsieve-1.9.3.tar.gz"