aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 08:49:18 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 12:10:40 +0000
commit2d7161c9cba7126c09d8f4ebd2525bf5b99515fb (patch)
tree57b74ce5e4d666b4374364ef332e283a092e25bd /testing
parent9b67a362fd8bbc7554d1c47f7486960da0f7a568 (diff)
downloadaports-2d7161c9cba7126c09d8f4ebd2525bf5b99515fb.tar.bz2
aports-2d7161c9cba7126c09d8f4ebd2525bf5b99515fb.tar.xz
testing/ktextwidgets: use xvfb-run to run testsuite
Closes GH-8392
Diffstat (limited to 'testing')
-rw-r--r--testing/ktextwidgets/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/ktextwidgets/APKBUILD b/testing/ktextwidgets/APKBUILD
index d502eabefb..92dd18b4fc 100644
--- a/testing/ktextwidgets/APKBUILD
+++ b/testing/ktextwidgets/APKBUILD
@@ -9,9 +9,9 @@ url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtspeech-dev kcompletion-dev kconfig-dev kconfigwidgets-dev ki18n-dev kiconthemes-dev kservice-dev kwidgetsaddons-dev kwindowsystem-dev sonnet-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running X11
build() {
cmake \
@@ -23,7 +23,7 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {