aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-06-21 19:28:25 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2017-06-22 00:28:36 +0200
commit2e8f3c81a67cc98fab76d3c7d87c517cec8da100 (patch)
tree4b82a2252890dfaad0dc50c950abdf98bfa44297 /testing
parent548113f245b757ed208a84784bf3e47825d25760 (diff)
downloadaports-2e8f3c81a67cc98fab76d3c7d87c517cec8da100.tar.bz2
aports-2e8f3c81a67cc98fab76d3c7d87c517cec8da100.tar.xz
testing/py-libnacl: upgrade to 1.5.1
Diffstat (limited to 'testing')
-rw-r--r--testing/py-libnacl/APKBUILD51
1 files changed, 27 insertions, 24 deletions
diff --git a/testing/py-libnacl/APKBUILD b/testing/py-libnacl/APKBUILD
index 47b621cf8f..ce9da1ff97 100644
--- a/testing/py-libnacl/APKBUILD
+++ b/testing/py-libnacl/APKBUILD
@@ -2,40 +2,43 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-libnacl
_pkgname=libnacl
-pkgver=1.4.3
+pkgver=1.5.1
pkgrel=0
pkgdesc="Python bindings for libsodium/tweetnacl"
url="https://libnacl.readthedocs.org/"
arch="noarch"
license="ASL 2.0"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
}
-md5sums="27f57f34ce6e0fe1dba7c754bd83773f libnacl-1.4.3.tar.gz"
-sha256sums="873614913c90c4011f791a8fd1448f6bb3ab7dc8cdd329d1baaa65e7e1d1a929 libnacl-1.4.3.tar.gz"
-sha512sums="92b7d5e8856e69404e8d5b9eee9f87374a4ba251b040c00f78b4c9e8094f5306241be0632c82f7c4edd88a9dd654cdd6323674a7789392d87064bd86cfbe66f2 libnacl-1.4.3.tar.gz"
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="8bc5e0e15b35814249b69b6c1270fdf2c45af808c3315a6499b25a4861f0b21fe1840630a08cf808c8dc840f417736dee9d020d21d5d1d697b8644bc2645b12e libnacl-1.5.1.tar.gz"