aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCorentin Henry <corentinhenry@gmail.com>2016-04-21 16:10:05 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-06-07 01:38:33 +0200
commit38310f978752fb7a21539e596e169a739a56fe02 (patch)
tree3c8e8230cba31af13b7d146dff1888262bcd5dde /testing
parentd2bf7137c317e74d7c7be269cb4c7e20a57ce255 (diff)
downloadaports-38310f978752fb7a21539e596e169a739a56fe02.tar.bz2
aports-38310f978752fb7a21539e596e169a739a56fe02.tar.xz
testing/py-ostinato: new aport
http://ostinato.org/ A Python agent for the ostinato controller
Diffstat (limited to 'testing')
-rw-r--r--testing/py-ostinato/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-ostinato/APKBUILD b/testing/py-ostinato/APKBUILD
new file mode 100644
index 0000000000..a3d31b8ea8
--- /dev/null
+++ b/testing/py-ostinato/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Corentin Henry <corentinhenry@gmail.com>
+# Maintainer: Corentin Henry <corentinhenry@gmail.com>
+pkgname=py-ostinato
+_pkgname=python-ostinato
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="A Python agent for the ostinato controller"
+url="http://ostinato.org/"
+arch="noarch"
+license="GPLv3"
+depends="python py-protobuf>=2.3.0"
+makedepends="python-dev py-setuptools"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="903d65182eeb09d1363c81375664c265 python-ostinato-0.7.1.tar.gz"
+sha256sums="f628f3be4c3392676ff703bac33ba6f51bcb951eed52ab9171dbeb4751c59bc0 python-ostinato-0.7.1.tar.gz"
+sha512sums="c80ba3783b551c3869529bb7b3636dd4370d9ff6dd8ea9c39484ea73982af940751a0a332641abb2bff9aa2860064337ec49a95dd507dc6afebb0544b1ae363e python-ostinato-0.7.1.tar.gz"