aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-30 07:55:41 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 19:04:00 +0000
commit3847d14f83c3d1040d25d09b225752fab900ecac (patch)
tree7836d4af8d9ba2561e05576bd8999cc23b30f12e /testing
parent48eb870251fefb4d1501a00fbb9797f4c0f8ec7c (diff)
downloadaports-3847d14f83c3d1040d25d09b225752fab900ecac.tar.bz2
aports-3847d14f83c3d1040d25d09b225752fab900ecac.tar.xz
testing/py3-pystache: modernize
- Enable tests - Use modern style
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pystache/APKBUILD49
1 files changed, 15 insertions, 34 deletions
diff --git a/testing/py3-pystache/APKBUILD b/testing/py3-pystache/APKBUILD
index 33f085afbf..dfd5fced34 100644
--- a/testing/py3-pystache/APKBUILD
+++ b/testing/py3-pystache/APKBUILD
@@ -1,55 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Paul Kilar <pkilar@gmail.com>
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Paul Kilar <pkilar@gmail.com>
-pkgname=py-pystache
+pkgname=py3-pystache
_realname=pystache
pkgver=0.5.4
-pkgrel=1
+pkgrel=2
pkgdesc="Pystache is a Python implementation of Mustache."
url="https://pypi.python.org/pypi/pystache"
arch="noarch"
license="MIT"
-options="!check"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+replaces="py-pystache" # For backwards compatibility
+provides="py-pystache=$pkgver-r$pkgrel" # For backwards compatibility
+depends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
builddir="$srcdir"/$_realname-$pkgver
-prepare() {
- default_prepare
- cp -r "$builddir" "$builddir-py3"
-}
-
build() {
- cd "$builddir"
- python2 setup.py build
- cd "$builddir-py3"
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- cd "$builddir"
- _py python2
+check() {
+ # This package uses 2to3 to convert itself to Python 3 on the fly
+ # So we need to jump through some hoops here
+ mkdir -p test_dir
+ python3 setup.py install --root=test_dir
+ PYTHONPATH=test_dir/usr/lib/python3.7/site-packages test_dir/usr/bin/pystache-test
}
-_py3() {
- depends="${depends//py-/py3-}"
- cd "$builddir-py3"
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
sha512sums="4ac325e1431f58f740218c9ec309821db82d89989ef4ca7fc3536dea0ef1c90e8e85ebaa7df27f33129ca02252b84bcbd7429a1ed999b496f62f174dd66502cb pystache-0.5.4.tar.gz"
+