aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-01 12:58:49 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-02 04:38:01 +0000
commit3da9d4239461e853723b0198f19df3b5e5251d75 (patch)
tree1be93c3a0f69768931e3502fa42de0f3e9ed37a5 /testing
parent92af3188a66adc82334e5bd9ae2f5d4c6f161fa8 (diff)
downloadaports-3da9d4239461e853723b0198f19df3b5e5251d75.tar.bz2
aports-3da9d4239461e853723b0198f19df3b5e5251d75.tar.xz
testing/otpclient: new aport
Highly secure and easy to use GTK+ OTP client (TOTP and HOTP) https://github.com/paolostivanin/OTPClient
Diffstat (limited to 'testing')
-rw-r--r--testing/otpclient/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/otpclient/APKBUILD b/testing/otpclient/APKBUILD
new file mode 100644
index 0000000000..a4417e4a7b
--- /dev/null
+++ b/testing/otpclient/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=otpclient
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Easy to use GTK+ OTP client"
+options="!check" # No testsuite
+url="https://github.com/paolostivanin/OTPClient"
+arch="all !aarch64" # due to zbar
+license="GPL-3.0-or-later"
+makedepends="gtk+3.0-dev glib-dev libgcrypt-dev libpng-dev libzip-dev zbar-dev
+ jansson-dev libcotp-dev cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/paolostivanin/OTPClient/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/OTPClient-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=ON
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0bbd61ea272d2fa1558ec2dcad1b51acdbae9c9d520d73f7f31d4bc3d84946de69f96f1212507b48f3efab6561a2d850f8868e8932f022ed184e6aa06d43205d otpclient-1.4.1.tar.gz"