aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-11-02 09:44:23 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-11-02 23:49:19 +0100
commit414b1d85dc88bd568767f07cae0d36dbcfd95d7e (patch)
tree9188cfeb6b1b4c457a6b90439bcf3e1d70aa952e /testing
parentb2578af8bd83ad9ce56f6ed5cfc9724b4e058d39 (diff)
downloadaports-414b1d85dc88bd568767f07cae0d36dbcfd95d7e.tar.bz2
aports-414b1d85dc88bd568767f07cae0d36dbcfd95d7e.tar.xz
testing/ripmime: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/ripmime/APKBUILD35
-rw-r--r--testing/ripmime/ripmime-1.4.0.10-makefile.patch63
2 files changed, 0 insertions, 98 deletions
diff --git a/testing/ripmime/APKBUILD b/testing/ripmime/APKBUILD
deleted file mode 100644
index 589be6bad8..0000000000
--- a/testing/ripmime/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=ripmime
-pkgver=1.4.0.10
-pkgrel=0
-pkgdesc="Tool to extract the attached files out of a MIME package"
-url="http://www.pldaniels.com/ripmime/"
-arch="all"
-license="BSD-3-Clause"
-depends=""
-makedepends=""
-install=""
-subpackages="$pkgname-doc"
-source="http://www.pldaniels.com/ripmime/ripmime-$pkgver.tar.gz
- ripmime-1.4.0.10-makefile.patch
- "
-builddir="$srcdir/ripmime-$pkgver"
-
-build() {
- cd "$builddir"
- make
-}
-
-check() {
- msg "Running testsuites..."
- "$builddir"/$pkgname --version > /dev/null
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="e1eae0ad93a50e19ab1966a6f95ae8704e59bc081f89da1e2894a3bb2a2eaea8b0fc4709ec29d126053517d56c72d6ee2a77f0d8e3fb5f223255d45e0b515ab0 ripmime-1.4.0.10.tar.gz
-a400e446a8de8ffa3c167155a601a5291b795e9875f51910c34b2f037cf5bf4cefb7e344bc3099878a36aa009d97e84c170dc6a5180721b4a82b7a1484a9c11d ripmime-1.4.0.10-makefile.patch"
diff --git a/testing/ripmime/ripmime-1.4.0.10-makefile.patch b/testing/ripmime/ripmime-1.4.0.10-makefile.patch
deleted file mode 100644
index 599cb71f7d..0000000000
--- a/testing/ripmime/ripmime-1.4.0.10-makefile.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- /tmp/Makefile
-+++ ./Makefile
-@@ -3,7 +3,7 @@
- #
- # 0.1.13: Added -I.
-
--LOCATION=/usr/local
-+LOCATION:=/usr
- VERSION=0.1.14
- # VERSION changes
- #---------------------
-@@ -42,22 +42,22 @@
- ./generate-buildcodes.sh
-
- ripOLE/ole.o:
-- ./build_ripOLE
-+ $(MAKE) -C ripOLE
-
- tnef/tnef.o:
-- ./build_tnef
-+ $(MAKE) -C tnef
-
- .c.o:
-- ${CC} ${CFLAGS} $(COMPONENTS) -c $*.c
-+ ${CC} ${CFLAGS} -fPIC $(COMPONENTS) -c $*.c
-
- all: ${OBJ}
-
-
- solib: ${OFILES} ripmime-api.o
-- gcc --shared -Wl,-soname,libripmime.so.1 ${OFILES} ripmime-api.o -o libripmime.so.1.4.0 -lc
-+ ${CC} ${LDFLAGS} --shared -Wl,-soname,libripmime.so.1 ${OFILES} ripmime-api.o -o libripmime.so.1.4.0 -lc
-
--libripmime: ${OFILES} ripmime-api.o
-- ar ruvs libripmime.a ${OFILES} ripmime-api.o
-+libripmime.a: ${OFILES} ripmime-api.o
-+ ${AR} ruvs $@ $^
-
- ripl: ripmime.a
- ${CC} ${CFLAGS} ripmime.c ripmime.a -o ripmime
-@@ -65,16 +65,18 @@
- sco: ${OFILES}
- ${CC} ${CFLAGS} ripmime.c ${OFILES} -o ripmime -lsocket
-
--ripmime: ${OFILES} ripmime.c buildcodes.h
-- ${CC} ${CFLAGS} $(COMPONENTS) ripmime.c ${OFILES} -o ripmime ${LIBS}
-+ripmime: ${OFILES} ripmime.o
-+ ${CC} ${CFLAGS} $(COMPONENTS) $(LDFLAGS) $^ -o $@ ${LIBS}
-
-+ripmime.o: buildcodes.h
-+
- riptest: ${OFILES}
- ${CC} ${CFLAGS} riptest.c ${OFILES} -o riptest
-
- install: ${OBJ}
- strip ripmime
-- cp ripmime ${LOCATION}/bin/
-- cp ripmime.1 ${LOCATION}/man/man1
-+ install -Dm775 ripmime ${DESTDIR}${LOCATION}/bin/ripmime
-+ install -Dm644 ripmime.1 ${DESTDIR}${LOCATION}/share/man/man1/ripmime.1
-
- ffget_test: ffget_mmap_test.c ffget_mmap.[ch] logger.o ffget_mmap.o
- ${CC} ${CFLAGS} ffget_mmap_test.c logger.o ffget_mmap.o -o ffgt