aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDaniel Everett <deverett@gmail.com>2018-09-02 05:20:11 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 05:47:30 +0000
commit41d8e803d40634c86459b0f173f28b85d3d0cf6c (patch)
tree952bdf75118afd36f1528f7c39b2e7557c443c4c /testing
parentfc9081e4197bb81ef1b9d1de204ba6fe56899d98 (diff)
downloadaports-41d8e803d40634c86459b0f173f28b85d3d0cf6c.tar.bz2
aports-41d8e803d40634c86459b0f173f28b85d3d0cf6c.tar.xz
testing/py-fido2: new aport
https://developers.yubico.com/python-fido2/ Provides library functionality for FIDO 2.0, including communication with a device over USB
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-fido2/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-fido2/APKBUILD b/testing/py3-fido2/APKBUILD
new file mode 100644
index 0000000000..f86e000751
--- /dev/null
+++ b/testing/py3-fido2/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Daniel Everett <deverett@gmail.com>
+# Maintainer: Daniel Everett <deverett@gmail.com>
+pkgname=py3-fido2
+_pkgname=${pkgname#py3-}
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Provides library functionality for FIDO 2.0, including communication with a device over USB"
+url="https://developers.yubico.com/python-fido2/"
+arch="noarch"
+license="BSD-2-Clause Apache-2.0 MPL-2.0"
+depends="py-cryptography"
+makedepends="python3-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ touch "test/__init__.py"
+ python3 setup.py test
+}
+
+sha512sums="c6ea83e104d77350413156eba4c1aa2635b77ae00d157dce61e5a8539c65aca4dd1dfc5303f9d408359582eeb98ae558aa1e2043a9b1dfcb23415eb8bc9c6a09 fido2-0.3.0.tar.gz"