aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-15 14:12:17 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-09-17 06:36:13 +0000
commit450e3c1cff385e4bcb8dd7ce56a755ed98195c32 (patch)
tree42701a5ebb4d6830324ab28fa27ed589020ece91 /testing
parente1bf8de5af362bdbd6db676d03f35b4591499277 (diff)
downloadaports-450e3c1cff385e4bcb8dd7ce56a755ed98195c32.tar.bz2
aports-450e3c1cff385e4bcb8dd7ce56a755ed98195c32.tar.xz
testing/py-ipython_genutils: new aport
dependecy for py-traitlets
Diffstat (limited to 'testing')
-rw-r--r--testing/py-ipython_genutils/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/py-ipython_genutils/APKBUILD b/testing/py-ipython_genutils/APKBUILD
new file mode 100644
index 0000000000..a2a972ddb3
--- /dev/null
+++ b/testing/py-ipython_genutils/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py-ipython_genutils
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Vestigial IPython utilities"
+url="https://github.com/ipython/ipython_genutils"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python2-dev python3-dev"
+options="!check" # No test suite
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython_genutils/archive/$pkgver.tar.gz"
+builddir="$srcdir/${pkgname#py-}-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="b238fce8ba437328b9cd78871cd8a8ab562c513d33db95be74296233114a39eb8a3b3c64fbfb149bc3d42d3eb7762defc03befb9862d6aefbaad389d2838f854 py-ipython_genutils-0.2.0.tar.gz"