aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 14:01:22 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 20:50:21 +0000
commit4637142b32d8f147c359c7f29b09fae3a532277b (patch)
tree20e85ed1e2ae5bd5ec0ba275111548cf3f7dfbf1 /testing
parentac725880844916878fa17dabc88d955eef439140 (diff)
downloadaports-4637142b32d8f147c359c7f29b09fae3a532277b.tar.bz2
aports-4637142b32d8f147c359c7f29b09fae3a532277b.tar.xz
testing/plata-theme: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/plata-theme/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/plata-theme/APKBUILD b/testing/plata-theme/APKBUILD
new file mode 100644
index 0000000000..8ca605aef2
--- /dev/null
+++ b/testing/plata-theme/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=plata-theme
+pkgver=0.7.7
+pkgrel=0
+pkgdesc="Gtk theme based on Material Design Refresh"
+url="https://gitlab.com/tista500/plata-theme"
+arch="noarch"
+license="CC-BY-SA-4.0 GPL-2.0-or-later"
+makedepends="
+ automake
+ autoconf
+ libtool
+ glib-dev
+ libxml2
+ sassc
+ inkscape
+ parallel
+ procps
+ zip
+ gdk-pixbuf-dev
+ gtk+2.0-dev
+ gtk+3.0-dev
+ gtk-murrine-engine"
+source="https://gitlab.com/tista500/plata-theme/-/archive/${pkgver}/plata-theme-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ autoreconf -fi
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-parallel \
+ --enable-telegram
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="66ae9aa32b65728062943f877cf07a2f2275f4d311f03f64f3463476da420abbf58be08b182627ec0668553f59941e533ea9cad3c4cb658e4d5ea8416b627bd6 plata-theme-0.7.7.tar.gz"