aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-07 13:46:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 12:17:13 +0000
commit479bd284a25fd374acd26ae175807642b7827499 (patch)
tree082f70ed5be5e44e860f1fbbcb2a12db745838c9 /testing
parent1224e1495e041c23c6b08a21596e7028699db22a (diff)
downloadaports-479bd284a25fd374acd26ae175807642b7827499.tar.bz2
aports-479bd284a25fd374acd26ae175807642b7827499.tar.xz
testing/libretro-freechaf: new aport
https://github.com/libretro/FreeChaf Fairchild ChannelF / Video Entertainment System emulator for libretro
Diffstat (limited to 'testing')
-rw-r--r--testing/libretro-freechaf/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-freechaf/APKBUILD b/testing/libretro-freechaf/APKBUILD
new file mode 100644
index 0000000000..be112ef6b6
--- /dev/null
+++ b/testing/libretro-freechaf/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-freechaf
+pkgver=0_git20200317
+pkgrel=0
+_commit="7076096c4e2d93acccab1b2429a6ed8530e98925"
+pkgdesc="Fairchild ChannelF / Video Entertainment System emulator for libretro"
+url="https://github.com/libretro/FreeChaf"
+arch="all"
+license="GPL-3.0-or-later"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/FreeChaF/archive/$_commit.tar.gz"
+builddir="$srcdir/FreeChaF-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 freechaf_libretro.so "$pkgdir"/usr/lib/libretro/freechaf_libretro.so
+}
+
+sha512sums="5e4d302b260a9aa94f2d578bff115954e549c304a264f4d24e9b41ec6ae7762c5b6e47ed858f5457b37dcc770068e9f3cb6aef8ed09343d2aa05015a886653a1 libretro-freechaf-7076096c4e2d93acccab1b2429a6ed8530e98925.tar.gz"