aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndrew Hills <ahills@ednos.net>2015-06-07 17:55:57 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-09 14:05:55 +0000
commit4d3b387a1c4f0ced8a6959cb334f79e4dc1874f1 (patch)
treeae6df837f552914d306d4892472a5d75c4377f5a /testing
parent5c11bd1c0e6bdca22db4c612a39987b40b4cc366 (diff)
downloadaports-4d3b387a1c4f0ced8a6959cb334f79e4dc1874f1.tar.bz2
aports-4d3b387a1c4f0ced8a6959cb334f79e4dc1874f1.tar.xz
testing/djvulibre: new aport
http://djvu.sourceforge.net An open source implementation of DjVu
Diffstat (limited to 'testing')
-rw-r--r--testing/djvulibre/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/djvulibre/APKBUILD b/testing/djvulibre/APKBUILD
new file mode 100644
index 0000000000..cebce43cc7
--- /dev/null
+++ b/testing/djvulibre/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=djvulibre
+pkgver=3.5.27
+pkgrel=0
+pkgdesc="An open source implementation of DjVu"
+url="http://djvu.sourceforge.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/djvu/djvulibre-$pkgver.tar.gz"
+
+_builddir="$srcdir"/djvulibre-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="aa4ed331f669f5a72e3c0d7f9196c4e6 djvulibre-3.5.27.tar.gz"
+sha256sums="e69668252565603875fb88500cde02bf93d12d48a3884e472696c896e81f505f djvulibre-3.5.27.tar.gz"
+sha512sums="62abcaa2fe7edab536477929ba38b882453dab1a06e119a3f838b38d5c61f5d8c252e4769e6534582b826e49bcfb490513179580fab9c3afa84aa92053ccebee djvulibre-3.5.27.tar.gz"