aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-03 16:19:22 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-05 12:42:59 +0000
commit4fe12248f98592715b004534e1ccc61355adf9ee (patch)
tree5a8f964a404c2a16827f553354511371d708053f /testing
parenteb799ff04a5bda677c8f7034980f642274f44e4a (diff)
downloadaports-4fe12248f98592715b004534e1ccc61355adf9ee.tar.bz2
aports-4fe12248f98592715b004534e1ccc61355adf9ee.tar.xz
testing/py-tinycss: remove obsolte APKBUILD
Diffstat (limited to 'testing')
-rw-r--r--testing/py-tinycss/APKBUILD55
-rw-r--r--testing/py-tinycss/disable-styling-checks.patch33
2 files changed, 0 insertions, 88 deletions
diff --git a/testing/py-tinycss/APKBUILD b/testing/py-tinycss/APKBUILD
deleted file mode 100644
index 29ca919e3f..0000000000
--- a/testing/py-tinycss/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor:
-# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer:
-pkgname=py-tinycss
-_pkgname=tinycss
-pkgver=0.4
-pkgrel=0
-pkgdesc="tiny CSS parser for python"
-url="https://pythonhosted.org/tinycss"
-arch="all"
-license="BSD"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="pytest-cov py-configparser py-futures"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- disable-styling-checks.patch"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="13a50332cddc28026fd7ecc007e14085976284e69de6ea93d1013502fd9791694092c010947b13dcd23f3a2df65f277f62410abd90d03eac16fa5af913673b0a tinycss-0.4.tar.gz
-8265e4c9e52fb8ae3f3041333aea46c3702e3657892a957db2117615d16b446bcadb96601fe0b8197d921997433b1a0e06a77a10ce74095687c59ed00f766def disable-styling-checks.patch"
diff --git a/testing/py-tinycss/disable-styling-checks.patch b/testing/py-tinycss/disable-styling-checks.patch
deleted file mode 100644
index bcc039e2f5..0000000000
--- a/testing/py-tinycss/disable-styling-checks.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -9,7 +9,7 @@
- test = pytest
-
- [tool:pytest]
--addopts = --flake8 --isort --cov --ignore=test/cairosvg_reference
-+addopts = --cov --ignore=test/cairosvg_reference
- norecursedirs = dist .cache .git build *.egg-info .eggs venv cairosvg_reference
- flake8-ignore = docs/conf.py ALL
- isort_ignore =
---- a/setup.py
-+++ b/setup.py
-@@ -99,9 +99,9 @@
- ],
- setup_requires=pytest_runner,
- tests_require=[
-- 'pytest-cov', 'pytest-flake8', 'pytest-isort', 'pytest-runner'],
-+ 'pytest-cov', 'pytest-runner'],
- extras_require={'test': (
-- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort')},
-+ 'pytest-runner', 'pytest-cov')},
- packages=['tinycss', 'tinycss.tests'],
- **kwargs
- )
---- a/tinycss.egg-info/requires.txt
-+++ b/tinycss.egg-info/requires.txt
-@@ -2,5 +2,3 @@
- [test]
- pytest-runner
- pytest-cov
--pytest-flake8
--pytest-isort