aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:20:49 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:21:34 +0200
commit50cf88b61df8a5172b3731f8def875301bbb18d7 (patch)
treedcd195c21aa3df78469c9baa6e0c7e89097ccee2 /testing
parente1f28eff9eeb597df26454d967cbb977cf931686 (diff)
downloadaports-50cf88b61df8a5172b3731f8def875301bbb18d7.tar.bz2
aports-50cf88b61df8a5172b3731f8def875301bbb18d7.tar.xz
testing/xbps: improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/xbps/APKBUILD49
-rw-r--r--testing/xbps/configure-fix-vasprintf-test.patch (renamed from testing/xbps/0001-configure-fix-vasprintf-test.patch)0
-rw-r--r--testing/xbps/fix-build-with-misleading-indentation.patch (renamed from testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch)0
-rw-r--r--testing/xbps/moving-_unused-macro-to-_unused_attr.patch (renamed from testing/xbps/0001-Moving-_unused-macro-to-_unused_attr.patch)0
4 files changed, 26 insertions, 23 deletions
diff --git a/testing/xbps/APKBUILD b/testing/xbps/APKBUILD
index e3f79ec417..c4eeca802c 100644
--- a/testing/xbps/APKBUILD
+++ b/testing/xbps/APKBUILD
@@ -1,6 +1,5 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
-
pkgname=xbps
pkgver=0.51
pkgrel=0
@@ -15,51 +14,55 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
- 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
- 0001-configure-fix-vasprintf-test.patch
- 0001-Moving-_unused-macro-to-_unused_attr.patch
- "
-builddir="$srcdir"/$pkgname-$pkgver
+ fix-build-with-misleading-indentation.patch
+ configure-fix-vasprintf-test.patch
+ moving-_unused-macro-to-_unused_attr.patch"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--bindir=/usr/bin \
- --localstatedir=/var/lib/xbps \
- || return 1
- make || return 1
+ --localstatedir=/var/lib/xbps
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- install -Dm644 COPYING.3RDPARTY "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -D -m 644 COPYING.3RDPARTY \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
}
bashcomp() {
- depends=""
pkgdesc="Bash completions for $pkgname"
+ depends=""
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
- mv "$pkgdir"/usr/share/bash-completion/completions/* \
- "$subpkgdir"/usr/share/bash-completion/completions/ || return 1
+ _submv usr/share/bash-completion/completions
}
zshcomp() {
+ pkgdesc="ZSH completions for $pkgname"
depends=""
- pkgdesc="Zsh completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
- mv "$pkgdir"/usr/share/zsh/site-functions/* \
- "$subpkgdir"/usr/share/zsh/site-functions || return 1
+ _submv usr/share/zsh/site-functions
+}
+
+_submv() {
+ local path="$1"
+ mkdir -p "$subpkgdir"/${path%/*}
+ mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
}
sha512sums="243dbef97bd94b05af1a79605f20050d00c6dfaffa8dbc56ea0b3b2d218a627fb45f157f9f82b6eb080f58a7445de9e7bf75d669f0be4caae262af5c5ac92262 xbps-0.51.tar.gz
-1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
-2de97a2fc9041ee456e58798d302028d428770fde775c21564a8ae8a7ba57393d7ff5e64680f8c62456a377df7528249278197030708050bb776470570e28416 0001-configure-fix-vasprintf-test.patch
-f4048531c35f86b08c85348b8e684edc576302f2da78a53214194532fada3246ba8310c19bf8bcc139da7c29843363c77002ccb37cd529e566be2ed39b484d6e 0001-Moving-_unused-macro-to-_unused_attr.patch"
+1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 fix-build-with-misleading-indentation.patch
+2de97a2fc9041ee456e58798d302028d428770fde775c21564a8ae8a7ba57393d7ff5e64680f8c62456a377df7528249278197030708050bb776470570e28416 configure-fix-vasprintf-test.patch
+f4048531c35f86b08c85348b8e684edc576302f2da78a53214194532fada3246ba8310c19bf8bcc139da7c29843363c77002ccb37cd529e566be2ed39b484d6e moving-_unused-macro-to-_unused_attr.patch"
diff --git a/testing/xbps/0001-configure-fix-vasprintf-test.patch b/testing/xbps/configure-fix-vasprintf-test.patch
index fcb99a8370..fcb99a8370 100644
--- a/testing/xbps/0001-configure-fix-vasprintf-test.patch
+++ b/testing/xbps/configure-fix-vasprintf-test.patch
diff --git a/testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch b/testing/xbps/fix-build-with-misleading-indentation.patch
index 7fb8bfdb78..7fb8bfdb78 100644
--- a/testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
+++ b/testing/xbps/fix-build-with-misleading-indentation.patch
diff --git a/testing/xbps/0001-Moving-_unused-macro-to-_unused_attr.patch b/testing/xbps/moving-_unused-macro-to-_unused_attr.patch
index d6f33dd972..d6f33dd972 100644
--- a/testing/xbps/0001-Moving-_unused-macro-to-_unused_attr.patch
+++ b/testing/xbps/moving-_unused-macro-to-_unused_attr.patch