aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-28 10:46:07 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:43 +0000
commit53979850556bda7b6ce35b79ecc3fe8fab820905 (patch)
tree238202940e32111a2b45a8525d73b8fda6158e9b /testing
parent523f9ab444d896b7c591bd89fd7abc1a6859c074 (diff)
downloadaports-53979850556bda7b6ce35b79ecc3fe8fab820905.tar.bz2
aports-53979850556bda7b6ce35b79ecc3fe8fab820905.tar.xz
testing/py3-trio: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-trio/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-trio/APKBUILD b/testing/py3-trio/APKBUILD
new file mode 100644
index 0000000000..befcbea267
--- /dev/null
+++ b/testing/py3-trio/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-trio
+pkgver=0.13.0
+pkgrel=0
+pkgdesc="A friendly Python library for async concurrency and I/O"
+url="https://trio.readthedocs.io/"
+arch="noarch"
+license="MIT OR Apache-2.0"
+depends="python3 py3-sniffio py3-outcome py3-idna py3-sortedcontainers"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/t/trio/trio-$pkgver.tar.gz"
+options="!check" # Requires macOS specific library
+builddir="$srcdir/trio-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="022e7923a68905400a0095a39b10c0216041e92bfbb2b7437140f212c1184a99e1e9a20196e1762ceb48236d5c67448f67ce476cd1dd07a1a526e712c54d5bd9 trio-0.13.0.tar.gz"