aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-03-13 09:36:37 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-15 11:58:15 +0000
commit5465bfa2f4c89813584f4440b882f7f443a4685c (patch)
tree87a6ecc1ff92b2fc5bf36544eac03df42ab2ffb5 /testing
parenta1516c7dd1ac1568a2aa90ea5c1bf86207847e7f (diff)
downloadaports-5465bfa2f4c89813584f4440b882f7f443a4685c.tar.bz2
aports-5465bfa2f4c89813584f4440b882f7f443a4685c.tar.xz
testing/unit: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/unit/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/unit/APKBUILD b/testing/unit/APKBUILD
new file mode 100644
index 0000000000..168bdb9c8c
--- /dev/null
+++ b/testing/unit/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=unit
+pkgver=0.6
+pkgrel=0
+pkgdesc="NGINX Unit is a dynamic web application server"
+url="https://unit.nginx.org/"
+arch="all"
+license="Apache2"
+depends=""
+makedepends="python3-dev"
+source="https://unit.nginx.org/download/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ ./configure python --config=python3-config
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./test/run.py
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5b667b1e7382df561574da25799c13ab3c1fc9f2ed975a61455589150d7936149816d3c7c1734abe38a1440a759ee225db3509f5696b4fae9fc90643a0b8ae79 unit-0.6.tar.gz"