aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRuss Webber <russ@rw.id.au>2019-10-27 14:42:44 +1100
committerRasmus Thomsen <oss@cogitri.dev>2019-10-27 10:52:58 +0100
commit5df6d7bdcf5b6ffc00df2a84fd3701eb4321bc5c (patch)
tree86aa012a1e3d90dc8872e46ab6219d33e16dd7d9 /testing
parent0950dd9074104d9bb3d8f0137284f144017aa74f (diff)
downloadaports-5df6d7bdcf5b6ffc00df2a84fd3701eb4321bc5c.tar.bz2
aports-5df6d7bdcf5b6ffc00df2a84fd3701eb4321bc5c.tar.xz
testing/py3-catkin-pkg: renamed from py3-catkin-pkg-modules
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-catkin-pkg-modules/APKBUILD26
-rw-r--r--testing/py3-catkin-pkg/APKBUILD27
2 files changed, 27 insertions, 26 deletions
diff --git a/testing/py3-catkin-pkg-modules/APKBUILD b/testing/py3-catkin-pkg-modules/APKBUILD
deleted file mode 100644
index 5054f478f8..0000000000
--- a/testing/py3-catkin-pkg-modules/APKBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# Contributor: Russ Webber <russ@rw.id.au>
-# Maintainer: Russ Webber <russ@rw.id.au>
-pkgname=py3-catkin-pkg-modules
-_pkgname=catkin_pkg_modules
-pkgver=0.4.13
-pkgrel=0
-pkgdesc="Standalone Python library for the catkin build system."
-url="http://wiki.ros.org/catkin_pkg"
-arch="noarch"
-license="BSD-3-Clause"
-options="!check" # python deps not packaged: flake8-blind-except flake8-builtins
- # flake8-class-newline flake8-comprehensions flake8-deprecated
- # flake8-docstrings flake8-import-order flake8-quotes
-depends="py3-docutils py3-dateutil py3-parsing"
-makedepends="python3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-sha512sums="7c8a69adfeceaf0578de76f4bb7c84cef94fa363f3e101981ed97f3f244c65d2dd9c79c3896e0b0bd98d663f38eeac2005aa4a834d03bf5e35813c1bf47817c6 catkin_pkg_modules-0.4.13.tar.gz"
diff --git a/testing/py3-catkin-pkg/APKBUILD b/testing/py3-catkin-pkg/APKBUILD
new file mode 100644
index 0000000000..631f85958b
--- /dev/null
+++ b/testing/py3-catkin-pkg/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Russ Webber <russ@rw.id.au>
+# Maintainer: Russ Webber <russ@rw.id.au>
+pkgname=py3-catkin-pkg
+_pkgname=catkin_pkg
+pkgver=0.4.14
+pkgrel=0
+pkgdesc="Standalone Python library for the catkin build system."
+url="http://wiki.ros.org/catkin_pkg"
+arch="noarch"
+license="BSD-3-Clause"
+options="!check" # python deps not packaged: # flake8-class-newline flake8-comprehensions flake8-deprecated flake8-docstrings
+depends="python3 py3-docutils py3-dateutil py3-parsing"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py3-catkin-pkg-modules" # module was renamed in pypi
+provides="py3-catkin-pkg-modules=$pkgver-r$pkgrel"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="95df6d07e4e3fe8b7ac6de67b6603fe2176b46601570aff8b13e38e2fc1574dfe4c600b32190e2ca5897d1e964c5e5de78c6e752db0fe3c26501565af10a6bff catkin_pkg-0.4.14.tar.gz"