aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 07:32:53 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 12:05:35 +0000
commit5e8b9362c290249811ea85aed89d137b36c08cc3 (patch)
tree1b6a41874b810039a6d853d59e2e5829f62fcefa /testing
parent2133e02eed67c829198e7f575852a07e29b42cec (diff)
downloadaports-5e8b9362c290249811ea85aed89d137b36c08cc3.tar.bz2
aports-5e8b9362c290249811ea85aed89d137b36c08cc3.tar.xz
testing/kio: make progress on running testsuite
Closes GH-8386
Diffstat (limited to 'testing')
-rw-r--r--testing/kio/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/kio/APKBUILD b/testing/kio/APKBUILD
index 216650fb40..0575d18f6e 100644
--- a/testing/kio/APKBUILD
+++ b/testing/kio/APKBUILD
@@ -7,11 +7,16 @@ pkgdesc="Resource and network access abstraction"
arch="all"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="qt5-qtscript-dev karchive-dev kconfig-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev ki18n-dev kservice-dev solid-dev kbookmarks-dev kcompletion-dev kconfigwidgets-dev kiconthemes-dev kitemviews-dev kjobwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kwallet-dev knotifications-dev"
+depends_dev="qt5-qtscript-dev karchive-dev kconfig-dev kcoreaddons-dev
+ kcrash-dev kdbusaddons-dev ki18n-dev kservice-dev solid-dev kbookmarks-dev
+ kcompletion-dev kconfigwidgets-dev kiconthemes-dev kitemviews-dev
+ kjobwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kwallet-dev
+ knotifications-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev libxslt-dev libxml2-dev kdoctools-dev"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running X11
+options="!check" # Fails due to requiring physical devices not normally available and test 14 hangs
build() {
cmake \
@@ -23,7 +28,7 @@ build() {
}
check() {
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {