aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-20 02:29:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-20 02:30:53 +0200
commit6331c4ac4c98464f6f1c8c9dd27967e4966ffd13 (patch)
tree2e70ed505ad7df2e196cfff0e18cc72bfde00066 /testing
parenta1c754060ae84bfa86044ff06ef6006b01c84f20 (diff)
downloadaports-6331c4ac4c98464f6f1c8c9dd27967e4966ffd13.tar.bz2
aports-6331c4ac4c98464f6f1c8c9dd27967e4966ffd13.tar.xz
testing/repmgr: fix runscript's depend(), remove rsync from depends
rsync is needed only in some cases
Diffstat (limited to 'testing')
-rw-r--r--testing/repmgr/APKBUILD6
-rw-r--r--testing/repmgr/repmgrd.initd5
2 files changed, 8 insertions, 3 deletions
diff --git a/testing/repmgr/APKBUILD b/testing/repmgr/APKBUILD
index 587d24b6af..b346d89a6c 100644
--- a/testing/repmgr/APKBUILD
+++ b/testing/repmgr/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=repmgr
pkgver=3.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Replication Manager for PostgreSQL"
url="http://www.repmgr.org/"
arch="all"
license="GPL-3"
-depends="postgresql-client rsync"
+depends="postgresql-client"
makedepends="postgresql-dev"
pkgusers="postgres"
subpackages="$pkgname-doc $pkgname-daemon"
@@ -54,4 +54,4 @@ daemon() {
sha512sums="98fba8fc0d9074e496c66762dbec45734fe279f39c9c51adb3e66dca929ac37f66a609789c8c658545856fd81f5afc5b35f6b5e389e52bce8c04ce8c52acd8dd repmgr-3.3.2.tar.gz
235a17d54ccce9e23b59919c0406fc3618f722e4f7559af6102c561668319a47beca7b70a9564432cb45bbbee091de9fc748935e7c771f1c84cfd40ab6e401a7 repmgr.conf.patch
-74a03cfd36d739ddfad2078ba88980c7dea983ebc664bc3ab4dc6792bf36f144d1cd9d2b1bfbd30dda7e2b1198e7eb388dbea616d9ad710602b775ad30b1a3ab repmgrd.initd"
+4ea90fc4b07898235eb3fd441a9f9857d2309e8c124e8e274ddcb44750db7aa2f59f03ac284ecba9150c1e17a8ae173cc5f493abfdc2b66cac3444802379c6e0 repmgrd.initd"
diff --git a/testing/repmgr/repmgrd.initd b/testing/repmgr/repmgrd.initd
index 5adb5c4547..46ed23f750 100644
--- a/testing/repmgr/repmgrd.initd
+++ b/testing/repmgr/repmgrd.initd
@@ -5,3 +5,8 @@ command_background="yes"
pidfile="/run/$RC_SVCNAME.pid"
start_stop_daemon_args="--user ${user:-postgres}"
+
+depend() {
+ need postgresql
+ use net logger
+}